RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
2003 Range Rover, 62,400 miles.. having a few more issues now. The odometer display and message center display are fading in an out. (see pics attached). Any ideas of what could be causing this? Also, upon start up - message center says Trans failsafe prog. It goes away after 15 seconds or so and does not come on while driving.. but once you turn the key off, the same message reappears. Had the car a week now and so far its just a big paperweight!

Just replaced alternator, serpentine belt, water pump pulley, and battery.... Issues with display and error message were happening before I replaced those parts.
 

Attachments

·
Registered
Joined
·
42 Posts
There's a few different threads about this, but hope this helps:

http://www.rangerovers.net/forum/viewtopic.php?f=2&t=30829&p=238099&hilit=dead+pixel#p238099

http://www.rangerovers.net/forum/viewtopic.php?f=2&t=34934&p=270501&hilit=dead+pixel#p270501

http://www.rangerovers.net/forum/viewtopic.php?f=2&t=27359&p=210023&hilit=dead+pixel#p210023

ps. yeah i have the same issue...it's not too bad as some cases, i can still tell what it says, but it is certainly annoying and I'm sure it'll progressively get worse, but I'll hold off until then... :?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the info. Im relieved to see that this is a normal issue on these cars and that it can be remedied with a new clustor from ebay! I'll mark it off the list of issues. Any thoughts on the trans failsafe prog message? Ive read on here others having the issue but seems like they had issues with it when the car was driving, etc... it only shows on mine when the car is first started and then again when the key is turned off.
 

·
Registered
Joined
·
80 Posts
if i remember correctly this message was tripped when you had the above mentioned issues correct? Did the dealer fix these issues for you? If so it sounds as if they did not clear the errors... someone please correct me if im wrong..
 

·
Registered
Joined
·
53 Posts
Trans failsafe prog is putting the car into limp home mode (usually just stays in 3rd gear) to protect the gearbox.

if you can get the fault code read it will tell you what is causing it.

i had this issue and replaced the inhibitor switch on the gearbox (quite straight forward) and never had the issue again. `)
 
G

·
Guest
Joined
·
0 Posts
PR4YME said:
Care for some LEMONade???
Seriously??
His car is 7 years old and has covered 64K miles...

Lemon Law defined:- "if any vehicle such as a car is under warranty period and is suffering from various defects that prevent a consumer to use the vehicle effectively then Lemon law act or the Magnuson Moss Act comes into force. "

The warranty period is over. Sounds more like neglect of the previous owner to me.
 

·
Registered
Joined
·
256 Posts
Rudi is the guy at BMWPixelfix. He does a great job and is very fast.
 

·
Registered
Joined
·
256 Posts
He also does an LED Upgrade which if you are having the LCD fixed its worth having it done as well.
 
1 - 13 of 13 Posts
Top