RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All i have an issue with my 2002 TD6 :-( starts but if you put your foot down at all it just ignores you, will slowly accelerate but god help you if you hit a hill!

checked the in tank fuel pump and can hear that running when you turn on the ignition (shuts off after about 30 seconds presumably got up to pressure) changed the fuel filter just in case but still wouldn't pull the skin off a rice pudding.
I think this is a fueling issue (though not sure) no faults on the dash.
anyone else encountered this type of problem? does any one know an easy test on the high pressure rail as i'm starting to suspect the high pressure pump or is there something i'm missing that i should check first?

Cheers Stuart
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Hi Peoples just a quick update on the gutless issue.due to work commitments and going on holiday i haven't had a lot of time to tinker with this but have had a good look at it yesterday and today ...and have managed to improve the situation significantly although i'm unsure what i did i had a spare injector loom so i thought as it was there and any easy swap i would do that first...no difference so i unplugged every thing i could see in the engine bay to check for possible corrosion etc no obvious issues so plugged it all back in and hea presto running a thousand times better??? but still suffering with a hesitation above 4000 revs which if i persist with my foot down suddenly dissapears when the gearbox catches up (presumably because the revs drop when the box goes up a notch) perfectly driveable as long as i dont want to give it full beans. so back under the bonnet to fanny around with all the wiring again in the hope that i was onto something, but alas neigh luck still hesitating in full wellie mode.unsure what else to try now as the problem is changing but still open to anymore suggestionsStuart
 
1 - 2 of 2 Posts
Top