RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
3 Posts
Discussion Starter #1
2002 L322 4.4 V8 "reservior pressure static when filling"

Happy new year everyone.

My 2002 L322 4.4 V8 is becoming a bit of a pain now. Went for my Mot passed no bother, on the way home air suspension inactive appeared hold button illuminated. Used all coms to read faults and got "reservoir pressure static when filling"


I've fitted brand new;

Compressor

Relay
A reservoir pressure sensor

But still the same fault, compressor seems to keep trying to fill tank only way to stop is to remove compressor relay.

Does anyone have any thoughts?? Other than a match Lol
Could be something I'm missing.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
869 Posts
Re: 2002 L322 4.4 V8 "reservior pressure static when filling

Normally, this code is associated with a worn compressor that times out as it tries to fill the tank.

But, Assuming the new compressor is working and actually filling the tank...then I think the issue revolves around the pressure valve at the tank sending the wrong signal. Curious...since the valve is integral to the tank, how did you replace it?
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
3 Posts
Discussion Starter #3
Re: 2002 L322 4.4 V8 "reservior pressure static when filling

Sensor screws into the end of air tank replaced with genuine LR sensor. So I'm starting to wonder if the air suspension ECU is at fault??
 
1 - 3 of 3 Posts
Top