RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
I have this big screen in center console same as this picture.



Car came with blurry TV reception, and with remote (SONY) saying 3 big button on top: T.V, NAVI, ITALY.

Pressing any key on remote have no effect even after i inserted new batteries. Looks like remote is bad, is there any way i can switch screen to Navi mode from TV mode w/o remote. I can only see one switch next to speedometer to switch this screen on/off.

Any luck in getting updated maps for this nav if somehow i start it up??????
 

·
Registered
Joined
·
640 Posts
That looks like a O.E Phillips/Vdo Dayton screen to me which which I don't think ever had a TV facility or Remote Control.
It might be possible someone has converted it to accept TV transmissions which may explain why the picture quality is poor. Somewhere there must be a reciever to accept the signals, be it for TV or Sat Nav.
The O.E navigation unit is normaly fitted in a housing located in the boot. Unless this has been change for a Sony Unit of some kind I'm not sure what the Sony remote is of any use for unless someone has been able to convert this to opereate the system.

Cheers
 

·
Registered
Joined
·
167 Posts
It doesn't appear to have the nav equipment in the "boot" so it may be a TV.

The antenna on the roof looks like it is laying down which may be causing the bad reception.
 

·
Registered
Joined
·
87 Posts
Discussion Starter #5
hmm thnks Terry. May be i was searching something that never existed.

TV antenna thingy i figured out later but still no luck with clear signal. Will probably insert some VHS to see if it show good quality video (just for fun).

I have 6 CD changer in boot inside left side of trunk space. Is Nav unit is separate?
 
1 - 6 of 6 Posts
Top