RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter #1
Hello all. My friend has a 2000 4.6 P38 that after turning off last night wont fire up this morning, engine cranks but not starting, fault code that return after each attempt are

P1667 imobilizer signal - CAN data bus, wiring short cirrcuit to earth.

anyone know if this is a common problem of a wire getting caught somewhere???

we also had

P1672 imobilzer signal incorrect code

but this didnt return so i guess not to worry about that for now...
 

·
Registered
Joined
·
520 Posts
Discussion Starter #3
Hiya Rick mate!

Well one of the fault codes ( P1672) would infur that, but that code didnt return! the one that did return ever time we attempted to start it (P1667) was concerning a wiring short circuit to earth!!
 

·
Registered
Joined
·
520 Posts
Discussion Starter #5
jamescherry said:
this is my car that mark is helping me to fix....... i hope this is going to be a easy fix Ha Ha
Hi James, Welcome aboard. Theres certainly some knowledgeable guys on here, im sure someone may be able to point you/us in the right direction to find the shorted wire, if the OBD codes are right!
 

·
Registered
Joined
·
520 Posts
Discussion Starter #6
Rick-the-Pick said:
Hi Mark,

The engine ecu needs to be resync'd into the becm. Easy as that buddy.

On second thoughts im wondering if its possible that a wire wil short to earth over night? the fault code pointed that way BUt would it happed when vehicle stsationary?

So maybe Rick is right (as he normaly is) and it is just the engine ecu and BeCM need to be re-aquainted??
 

·
Registered
Joined
·
820 Posts
It's the bosch motronic. It's a common problem. There's no earth shorting out, that's just your quality OBD reader pulling your leg.

Mark, get the EMS code from the motronic ecu re-written back to the becm.

The resyncer from blackbox was made especially for this problem. I think they cost £90. Damnit, wish i come up with these ideas.
 

·
Registered
Joined
·
4 Posts
today i checked and tried the EKA code ......
i locked the car first with the fob and all the doors locked then i put the EKA code in and all the doors unlocked but when i tried to start the car it will spin over but will not fire.
is there anything else that i need to do or is the fault somewhere else?
 

·
Registered
Joined
·
820 Posts
I've already told you what it is.

I've told you what you can buy to fix your problem.

Do you know how many times i come across your problem?

You can sort it out yourself if you purchase the resyncer from blackbox. That tool was made especially for your problem.
 

·
Registered
Joined
·
4 Posts
you said Mark, "Mark, get the EMS code from the motronic ecu re-written back to the becm" is this only done with a sync tool? wonder if anyone local has a tool i could borrow lol or would it be better to buy a unit and wait till the car messes up again. oh does the RAC have a sync tool????
 

·
JACK'S GRANDAD
Joined
·
9,235 Posts
At the top of the page is the manufacturer he was talking about. Blackbox solutions.
I would either
Go to a dealer/indy and get it reset
Buy the tool and be done with it.
Anything else and you are just wasting your time.
 
1 - 13 of 13 Posts
Top