RangeRovers.net Forum banner

21 - 36 of 36 Posts

·
Registered
Joined
·
5 Posts
So far no problems here. The mute-satnav-bug seems finally fixed.

For me, what remains to be improved is startup-time and reducing the lag of the cameras and the sat nav position display. as well as some minor issues with the TCU (such as no data connection if car is started in area without reception, that is still a problem).

Otherwise I am really close to happy now. At last ;)
I totally agree with your every word.
I have absolutely exactly the same problems as you’re describing.
 

·
Registered
Joined
·
5 Posts
I almost forgot - one more stupid problem - the buttons on the wheel - when you switch music tracks it works as it should - upper arrows (pointing to the right) switch to the next song, and lower to the previous.
BUT! If I try to switch my favorite radio stations - it does totally opposite - so upper button switch to the previous radio station and lower switch to the next! AAaaaaaaaaa🤯🤯🤯
282845
80C84BF7-3F2F-4FE0-A27A-C3FCAE35D6B2.jpeg
 

·
Registered
Joined
·
84 Posts
Discussion Starter #24
It's not downloading while off, nor installing while off. It goes from "downloading" through "installing" to "ready" while driving or at least ignition on, and after that it reboots and finalizes as soon as the car has been off and locked for 15 minutes or so. It can't download or install while off because that would need a very complicated chain of devices and processes to remain powered on, like the TCU for data transfer, and they won't do that to avoid battery surge.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #25
I almost forgot - one more stupid problem - the buttons on the wheel - when you switch music tracks it works as it should - upper arrows (pointing to the right) switch to the next song, and lower to the previous.
BUT! If I try to switch my favorite radio stations - it does totally opposite - so upper button switch to the previous radio station and lower switch to the next! AAaaaaaaaaa🤯🤯🤯
Funny bug, never noticed, as I never listen to radio.
 

·
Registered
Joined
·
44 Posts
Regarding navigating the radio favorites from the steering wheel:

What it seems to do is list the favorites in the order they were saved instead of numerical order. Can’t tell if that’s a bug or misguided feature. I guess if you set it up knowing that you could arrange your favorites from most to least used.
 

·
Registered
Joined
·
5 Posts
Regarding navigating the radio favorites from the steering wheel:

What it seems to do is list the favorites in the order they were saved instead of numerical order. Can’t tell if that’s a bug or misguided feature. I guess if you set it up knowing that you could arrange your favorites from most to least used.
Thank you for the advice! I didn’t know that I can manually arrange them. Just did as you wrote - and everything is perfect now 😉
 

·
Registered
Joined
·
167 Posts
I got the OTA update yesterday. This morning when I got in the car (started it and let it sit for several minutes) I had a lot of quirky behavior. The temperature dials for the climate control system had changed to Celsius with no apparent way to change them back, and the entire system was very slow to respond to any touch input. After I stopped and shut the car off for an hour or so, the temperature dials reset themselves, but the system is still very slow to respond to touch inputs. Not overly impressed with this update so far.
 

·
Registered
Joined
·
159 Posts
Regarding navigating the radio favorites from the steering wheel:

What it seems to do is list the favorites in the order they were saved instead of numerical order. Can’t tell if that’s a bug or misguided feature. I guess if you set it up knowing that you could arrange your favorites from most to least used.
I agree with this... it goes to the favorites in the order you saved them.
 

·
Registered
Joined
·
83 Posts
Just received the update. I requested it over 10x during a drive and for whatever reason then it popped up randomly. For those that haven’t received the software update notice perhaps continuing to request it will result in the same.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
44 Posts
Still no update found for my 20 either. I do have access to Topix and could force the update if I wanted to but, honestly, since I haven't had any issues with 19b i'm tempted to leave it alone.
 

·
Registered
Joined
·
1 Posts
I have a 2017 RRS and I now have issues with Android Auto with this release. My touch screen does not work once I connect my android phone anymore. it was working fine in v 19B. Any one else having issues with Android auto with this release?
 
21 - 36 of 36 Posts
Top