RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
1995-2002 Range Rover Classic
Joined
·
25 Posts
Discussion Starter #1
Hi All,

New to this forum!! Had the car of my dreams - 1995 Country Classic for about 9 months, and recently we have been experiencing very intermittent warm start issues. Will start great and run great. Stop at the grocery, get back in, and sometimes the truck will idle irregularly (always low idle speed). One time after using the A/C, it died and refused to start for 20 minutes, :cry: then started and ran ok - almost like a vapor lock.....

Would greatly appreciate any input. I LOVE this rig, and want to figure out what may be wrong with it!

Thanks!
 

·
Registered
Joined
·
74 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

Do a search here and you can find a few threads on problems that might shed some light on your problem. At the top of page there is a pinned thread on electrical problems and that might be helpful since battery or alternator problems can cause all sorts of problems.

We have a problem like yours (Is it worse if it is a warm or hot day? Does it start fine if it has had an hour or so to cool or if you start it right up?) and so far it has not been solved. So far we have: Cleaned grounds and other electrical connetions, replaced the battery (a coupld of cells going bad), replaced the alternator (slightly low output), new plugs and plug wires, rotor and cap, new Idle Air Control valve (also called the stepper motor), cleaned the MAF, ran Sea Foam through the intake system, checked for vacum leaks, new air and fuel filters and a new ignition module (I think the '95s, or at least ours had the remote mounted ignition module so it is next to the coil, not on the distributor). Also checked dwell and timing and the mechanical advance.

Not sure the next step, possibly replacing the coil and or the condensor but I am begining to think it might be a fuel system problem but right now I am stuck. Yeah, our problem reminds me of vapor lock but I don't know enough about fuel injection to start guessing.
 

·
Registered
Joined
·
104 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

Fellas, I had this issue and posted about it here not too long ago. I was throwing code 24. Fuel system issue. Someone on here posted about vapor lock from your gas cap. If it hisses when you open the cap, you have your culprit. Mine hasn't hesitated once on me since I've monitored how tight, or I should say loose, I keep my cap. In fact, my wife used my rig while I was out of town and she filled up not knowing about the cap issue and the stalling came back. After she loosened the cap, all was well. Hope yours was as easy as mine.
 

·
Registered
Joined
·
300 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

I had the hot start problem for over a year; I replaced most of the ignition system, filters, before someone suggested the fuel injectors could be the culprit :think:

They were right, the car was fine when cold, but once hot they must have been dribbling; and so when the car was left for any period the fuel would build up in the cylinders and make it very difficult to start.

I now have no problems getting it to start, it has more power and the idle is rock steady :D
 

·
Registered
Joined
·
170 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

There is an injector refurbish service offered on a Volvo forum i'm on. I had similar problems. Had them serviced, I now get better performance, better economy and better idling. Ok its a different engine entirely but the principle is the same.
 

·
Registered
Joined
·
23 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

I had all the same issues as yours, changed a ton of stuff and it turned out to be Fuel injectors as said above.
The yellow/gold tops are cheap 19lb on e-bay.
Good luck
 

·
Registered
Joined
·
81 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

Having similar issues.... Looked on Ebay, but not sure what to search.... tried 19lb injector range rover and nothing.... is there a better search I should use?
 

·
Registered
Joined
·
374 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

Just to throw my $0.02 in, I had a similar hot/warm start issue and I also believed it to be leaky injectors flooding the cylinder. Turned out to be a fuel pump that was intermittently going out. Figured this out once the fuel pump bit the dust. I replaced it and haven't had a problem since.
 

·
Registered
Joined
·
1 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

Check the stepper motor aka the idle control module. It's likely just dirty or possibly needs replacing. I had the same problem, then cleaned and finally replaced it and it's been running smoothly since then.

O
 

·
Registered
Joined
·
100 Posts
Re: 1995 Country Classic Sometimes has Idle Prob W/Warm Start

im right there with ya man... same issue and it sucks. its been like the surface of the sun here in Nevada and i dread driving during the hottest part of the day because of this issue. I will be tackling it soon and will start with injectors.
 
1 - 11 of 11 Posts
Top