RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1970-1995 Range Rover Classic
Joined
·
2 Posts
Discussion Starter #1
I have recently acquired a 1993 Range Rover and I'm having trouble getting it to idle. I've cleaned the IACV which resolved the issue of it not idling at all but it still idles very low when in gear and tries to stall.

when it's in park or neutral it will idle and rev fine but it seems to bog down when I try to accelerate when in gear.

Any Ideas on what could be causing this?
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
359 Posts
I have recently acquired a 1993 Range Rover and I'm having trouble getting it to idle. I've cleaned the IACV which resolved the issue of it not idling at all but it still idles very low when in gear and tries to stall.

when it's in park or neutral it will idle and rev fine but it seems to bog down when I try to accelerate when in gear.

Any Ideas on what could be causing this?
Cleaning an ICV doesn't mean it's fixed.

Change it
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
143 Posts
Is there a governor on the gearbox which sends a signal when selecting other than N or P to the ECU to balance out the load with more revs. Could that be sticking / broke?
 

·
Registered
1995-2002 Range Rover Classic
Joined
·
1,413 Posts
Is there a governor on the gearbox which sends a signal when selecting other than N or P to the ECU to balance out the load with more revs. Could that be sticking / broke?
nope, it uses speed sensor as an idle reference. visit britishv8 for further info.
 
1 - 4 of 4 Posts
Top