RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello everyone. I just bought an 88 RR classic. She looks to have good bones but I'm having shifting issues. It doesnt seem to want to shift as it should. And when it does it's a very hard shift. Even going into gear R or D it seems to clunk hard. Any ideas? I've ordered new trans filter and will be changing fluids too. Any help would be greatly appreciated.

Thanks, Carey
 

Attachments

·
Registered
Joined
·
100 Posts
nice! i hate the wheels though but the paint is flawless... im thinking of rattle canning my roof white to cover up the sun damage... looks good on your rover...
welcome and best of luck with the mechanicals...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Hey everyone.... been awhile since i posted about my 88 Rover. I tried draining fluids and putting all new fluids and filter. My shifting problems have not gone away. ;( What other models can I effectively use if I replace the trans? Can I use a trans out of a discovery? If so what years?

Also I have a new issue. My rover won't start now. Turns over but no fuel is getting to engine. we pulled fuel pump and hooked it up to battery and it cycles.... I got caught in a HEAVY downpour and the sunroof began to leak terribly! After I got home and parked it all seemed fine. But ever since then it will not start. I also seem to have something draining my battery, and when I go charge battery it won't charge unless I unhook battery from cables.

So a few questions....

1. Possible short somewhere?
2. Passenger seat got wet with rain... control box and relays under seat?? If so where to get??
3. What years are interchangeable? and what models?
4. Finally where can I find a sunroof gasket to fix my leaking sunroof??

This is my first rover and I am not terribly knowledgeable on them. I am relying on a buddy for most of my mechanical work but any help from this great community would be awesome.
Thanks in advance
 

·
Registered
Joined
·
23 Posts
Your sun roof has a drain in each corner that may be clogged. I know the front ones look like a small plastic tube that drains between the bonnet and the front wings. If these are clogged it may leak into the vehicle. To clear them use compressed air and blow from the bottom up and see if anything comes out.

My fuel pump was turning but would not supply enough fuel for the engine, as soon as I replaced it she started right up!!
It sounds like the water could have gotten to the ECU which I believe is under the passenger seat.

Have you checked the universal joints on the prop shafts yet to see if the CLUNK is coming from them?

I love the white roof and have been thinking about doing the same to mine. The PO painted it with bed liner and did a terrible job, now it's peeling.

Brian
 

·
Registered
Joined
·
74 Posts
As far as the engine starting issue. I was having a issue like this and it turned to be a poor connection between the relay and the inertial switch under the drivers seat. It is easy enough to bypass it as a very temporary fix.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Thanks to everyone who has replied... Once it ever warms up I will begin again on this. If I need to replace the ecu is there anyone out there that may have an extra one.... and the relays that are under that seat as well.... I have access to a 96 discovery that I can get parts off of.... would it have a compatible ecu? or starter?? or any other parts?? Thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Hey everyone....

Quick question as I start trying to figure out my starting issue:

I am thinking of replacing ECU .... part # 84778a and PRC 6977 on label I think....

question is I cant find a PRC 6977 but can find one PRC 5053 and #84556D both came out of same year.... are they interchangeable?

Thanks Again!!
 
1 - 9 of 9 Posts
Top