RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2013-2015 Range Rover Evoque
Joined
·
66 Posts
Discussion Starter #1
Had H&R lowering springs installed last summer... all was good, but this clunking noise started and progressively got worse over time.
Sounds identical to having a worn sway bar link.
Had the car up in the air...
Sway links, good
Ball joints, good
Tie rods, good
Control arm and sway bushings, good...

I actually disconnected BOTH sway links and drove the car, no change.

Only thing I can think of is maybe strut mount? Strut bearing?
Ideas?
 

·
Registered
2013-2015 Range Rover Evoque
Joined
·
66 Posts
Discussion Starter #2
Going over the threads, it looks like swaybar bushings are a common problem on other LR models...
Something to look at.
 

·
Registered
2013-2015 Range Rover Evoque
Joined
·
66 Posts
Discussion Starter #4

·
Administrator
Joined
·
27,799 Posts
Had H&R lowering springs installed last summer... all was good, but this clunking noise started and progressively got worse over time. Strut bearing?
Ideas?
Strut bearing? Put your Evoque on ramps, block rear tyres and have someone bounce the front of the car. You should easily be able to locate what is clunking.
 

·
Registered
2013-2015 Range Rover Evoque
Joined
·
66 Posts
Discussion Starter #6
I've had it up in the air and pry barred everything I could think of. Bouncing the suspension up and down at the front is very difficult with the H&R Springs!

Sent from my SM-G965W using Tapatalk
 
1 - 6 of 6 Posts
Top