RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
SUPER MODERATOR
Joined
·
979 Posts
Discussion Starter #1
We're trying to trace back some consistent battery drain issues on a MY2012 HSE my Aunt owns. Something we've noticed twice is the way the backlight on the gauge cluster screen just doesn't turn off sometimes. The image fades to black but the backlight remains lit and actually pulses a little. It's something you can only see at night and is very intermittent. Dealer can't find what was causing the drain that's requires a jump twice now. We just found the backlight issues on Friday.

Has anyone seen this before?

Thanks.
 

·
SUPER MODERATOR
Joined
·
979 Posts
Discussion Starter #2
I realize no one's seen this before. We've gotten pictures of it tonight - adding them here for reference.

It's finally going in for service on Tuesday.

These two pics aren't great, it was at night with a lot of reflections and we obviously couldn't open the doors or do anything that would change the circumstances. The car had been sitting for at least 5 hours when I happened to be walking past and saw it was happening again.

You can see the screen is constantly illuminated and it actually pulsates, darker to lighter.
 

Attachments

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
1 Posts
Did you ever figure this out? My splash screen only flashes briefly then goes to black screen
 

·
Registered
Joined
·
4 Posts
I realize no one's seen this before. We've gotten pictures of it tonight - adding them here for reference.

It's finally going in for service on Tuesday.

These two pics aren't great, it was at night with a lot of reflections and we obviously couldn't open the doors or do anything that would change the circumstances. The car had been sitting for at least 5 hours when I happened to be walking past and saw it was happening again.

You can see the screen is constantly illuminated and it actually pulsates, darker to lighter.
Hi there did u figure out what the problem was
Thanks
 
1 - 4 of 4 Posts
Top