Range Rovers Forum banner
481 - 488 of 488 Posts

·
Registered
Joined
·
594 Posts
I think you might have the button packs backwards. I’m pretty sure it’s the left one that is supposed to stay attached.
Yeah that’s what they said on the powerful UK video, but on one of Ray’s it says the right one stays.right. I don’t think I’d get this much functionality if I missed on that. I see you had two raps on there. What were you running with those? Anything I’d require?
 

·
Registered
2021 Westminster P525 - Eiger Grey
Joined
·
101 Posts
Yeah that’s what they said on the powerful UK video, but on one of Ray’s it says the right one stays.right. I don’t think I’d get this much functionality if I missed on that. I see you had two raps on there. What were you running with those? Anything I’d require?
Regarding those taps: you can remove them. After I pulled the unit out, I realized I forgot to clear out/reset all of my Google accounts. So I added the taps so I could hook to a battery to power up and clear the settings without having to reinstall the whole thing.
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,116 Posts
Discussion Starter · #484 ·
Was your original Home Screen reduced in size like this?
View attachment 296293 View attachment 296293
DaveCap, that's an easy fix...you just need to go into the FactorySet menu and find the correct configuration for your vehicle. All of my units include the instructions on how that's done but if you don't have it then I can assist you on Monday.
 

·
Registered
Joined
·
594 Posts
DaveCap, that's an easy fix...you just need to go into the FactorySet menu and find the correct configuration for your vehicle. All of my units include the instructions on how that's done but if you don't have it then I can assist you on Monday.
Yes, I see a password is required. Is there also a setting in there to get sound through CarPlay that I missed?
And the frozen touch screen in original?
 

·
Registered
Joined
·
594 Posts
All good now. Great unit. Just want to clarify that all the issues I was having was due to me not choosing the appropriate settings and a slight learning curve. In no way was it a hardware or software issue. Great product. Even though I bought it second hand (thank you pherplexed), Ray still walked me through the settings. I don’t think our friends from China could do that. If you’re on the fence, do it. As to where to buy, choose wisely.
 

·
Registered
Joined
·
594 Posts
Agree with above poster....love my unit. Would like the climate/seat climate. Only other weird qualm is if I hit the "left"/"skip back" button on the left steering wheel pack buttons it cues Google speak screen which you have to manually close out of each time.
Did you ever figure this out. I'm at this point now. Not a big deal, but would like to know if I can stop it with a setting I missed.
 
481 - 488 of 488 Posts
Top