Range Rovers Forum banner

401 - 420 of 444 Posts

·
Registered
Joined
·
181 Posts
I say go ahead and upgrade to the 9.0 version. I offer a 10% discount to previous customers. The full screen option is for the OEM interface...on the 7.1 version, you could select full screen so that the virtual buttons for the side button packs don't show.

Haha. I figured that! I didn't like the full screen for the OEM anyway.

So I'm clear on the 9.0 version, as it relates to climate control and heated seats .... If I'm in CarPlay mode and I want to change 'what is heated' on the seats and / or specifically change aspects of the climate control settings, I need to leave CarPlay and dive into the OEM screen through the steps previously described. I would like to confirm that if want to simply 'turn on heated seats' or use 'Auto' on the climate control, for example, that I am able to do that by pressing the Hard Buttons on the dash.

Hopefully thats clear. If anyone can post a video, that would be appreciated. Thank you.
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #402 ·
Haha. I figured that! I didn't like the full screen for the OEM anyway.

So I'm clear on the 9.0 version, as it relates to climate control and heated seats .... If I'm in CarPlay mode and I want to change 'what is heated' on the seats and / or specifically change aspects of the climate control settings, I need to leave CarPlay and dive into the OEM screen through the steps previously described. I would like to confirm that if want to simply 'turn on heated seats' or use 'Auto' on the climate control, for example, that I am able to do that by pressing the Hard Buttons on the dash.

Hopefully thats clear. If anyone can post a video, that would be appreciated. Thank you.
The hard climate buttons on the dash still work. However, if you want to access the buttons on the screen then you will need to switch to the OEM display using the steps mentioned above. I don't think you need to switch over just to select AUTO...just press the AUTO hard button. My 2016 has the heated seat option on the hard buttons as well so no need to switch over to OEM screen...I just press the climate control knob and the heated seat option will show in the little window of the control knob, then turn the knob to adjust.
 

·
Registered
Joined
·
181 Posts
Just picked up my '16 SC. Decided to leave the 7.1 in the '14 so planning on getting the 9.0 soon.

BTW, the GM was shocked at how good the Unit was. 'Just like factory' is what he said.

Based on what I see with the '16 heat seat controls (on/off, low/med/high) integrated wit the physical climate control button, I don't think there will be any need for me to dive into the OEM screen on a regular basis. I'd say the same thing about the climate control thing that has been mentioned, because I run it synched and on Auto and rarely mess around with the flow.

One question though, one of my larger frustrations with 7.1 was maintaining the bluetooth connection and reestablishing when I lost it. If there are in tips to increase the reliability of this, please let me know.

Thank you.
 
  • Like
Reactions: W84IT

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #404 ·
Just picked up my '16 SC. Decided to leave the 7.1 in the '14 so planning on getting the 9.0 soon.

BTW, the GM was shocked at how good the Unit was. 'Just like factory' is what he said.

Based on what I see with the '16 heat seat controls (on/off, low/med/high) integrated wit the physical climate control button, I don't think there will be any need for me to dive into the OEM screen on a regular basis. I'd say the same thing about the climate control thing that has been mentioned, because I run it synched and on Auto and rarely mess around with the flow.

One question though, one of my larger frustrations with 7.1 was maintaining the bluetooth connection and reestablishing when I lost it. If there are in tips to increase the reliability of this, please let me know.

Thank you.
Can you be more specific? Are you referring to the CarPlay Bluetooth connection?
 

·
Registered
Joined
·
181 Posts
Can you be more specific? Are you referring to the CarPlay Bluetooth connection?
Good question. I typically connected wirelessly and from what I recall, my 7.1 used my Range Rover Bluetooth and the AutoPlay. Sometimes i would get a CarPlay specific option, but not typically. Sorry for not being able to articulate this better!
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #406 ·
Good question. I typically connected wirelessly and from what I recall, my 7.1 used my Range Rover Bluetooth and the AutoPlay. Sometimes i would get a CarPlay specific option, but not typically. Sorry for not being able to articulate this better!
The 7.1 version didn't have the Bluetooth Emission option like the 9.0 version does. The 7.1 version only used the AUX for audio. Maybe you had your phone connected to the Range Rover Bluetooth for audio. I'm using the 9.0 version Bluetooth Emission for audio in my 2016 L405 and it has been solid. I also use the wired CarPlay option instead of wireless. Call me if you're confused about how this is done.
 

·
Registered
2014 Vogue Silver with 22" wheels
Joined
·
3 Posts
The 2 video connectors on the harness are for cameras...Front DVR and Rear View
LeRay / I’ve just bought a 2014 L405 and am about to buy one of your units. I only have the standard rear camera. Can I add a front camera to the Android unit and have it switch between front and rear cameras? Is that functionality supported? Many thanks! Are you still offering discount for members here?
John
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #409 ·
LeRay / I’ve just bought a 2014 L405 and am about to buy one of your units. I only have the standard rear camera. Can I add a front camera to the Android unit and have it switch between front and rear cameras? Is that functionality supported? Many thanks! Are you still offering discount for members here?
John
Hello John,
Yes, your original rear camera will still function the same and the Android unit also has inputs for 2 aftermarket cameras on the harness. I have never used either of those inputs but the unit has a settings menu to switch from the original to the aftermarket cameras. I will PM you the forum discount.
 

·
Registered
2016 Range Rover HSE V6 Supercharged
Joined
·
52 Posts
This is an amazing upgrade! Just one question for y’all; Apple maps, Google maps and Waze are lagging behind the route or frozen completely, both wired or wireless.

Anyone else experiencing this? Any solution? Or if it works perfectly with others, happy to know as problem is then on my end:)

thanks,
Dan
 

·
Registered
Joined
·
181 Posts
I didn't have this issue with v7 or v9. How is your cellphone connectivity and do you have data roaming turned on?
 

·
Registered
2016 Range Rover HSE V6 Supercharged
Joined
·
52 Posts
I didn't have this issue with v7 or v9. How is your cellphone connectivity and do you have data roaming turned on?
both apps work perfectly on the phone itself, so quite stumped as it apparently doesn't have a good connection with the headunit to give thru the information. Roaming is on. I have the v9 btw
 

·
Registered
Joined
·
181 Posts
I know that Ray recommends using the CarPlay dongle and not the BT thats built into the unit. Also, if you haven't done this, maybe try wired (not wireless) and see if you have the same issue.
 
  • Like
Reactions: W84IT

·
Registered
2016 Range Rover HSE V6 Supercharged
Joined
·
52 Posts
I know that Ray recommends using the CarPlay dongle and not the BT thats built into the unit. Also, if you haven't done this, maybe try wired (not wireless) and see if you have the same issue.
thanks, tried that, unfortunately same issue when wired (and BT/Wifi off to make sure). You also use iPhone? perhaps there's an issue with latest iOS 14.4 update
 

·
Registered
2014 Vogue Silver with 22" wheels
Joined
·
3 Posts
I fitted this unit a couple of weeks ago and it works really well. I connected my phone bluetooth to the wireless CarPlay dongle - and then use the AutoPlay app on the head unit for CarPlay.
I have two questions though:
1. When I turn the car off with the button, the head unit powers down after about 3 seconds - is there a way to wire a more persistent 12 volt supply that stays on - like the centre arm rest 12 volt outlets that stay on 3 minutes after shutdown?
2. Does anyone know how to change the head unit android icons so that AutoPlay is on the front page? Just now you have to swipe right, select Apps, then select AutoPlay... minor but would be good if we can shuffle apps around.

Thanks to Ray for providing a great product and splendid support

John
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #416 ·
I fitted this unit a couple of weeks ago and it works really well. I connected my phone bluetooth to the wireless CarPlay dongle - and then use the AutoPlay app on the head unit for CarPlay.
I have two questions though:
1. When I turn the car off with the button, the head unit powers down after about 3 seconds - is there a way to wire a more persistent 12 volt supply that stays on - like the centre arm rest 12 volt outlets that stay on 3 minutes after shutdown?
2. Does anyone know how to change the head unit android icons so that AutoPlay is on the front page? Just now you have to swipe right, select Apps, then select AutoPlay... minor but would be good if we can shuffle apps around.

Thanks to Ray for providing a great product and splendid support

John
John, it's good to know that you're enjoying your new unit. We have a forum member here who's working on an add on device that will start the boot time as soon as you unlock the car/open the door. I think he also mentioned that it will keep the unit powered after you shut down the vehicle until you open a door.

As far as changing or moving the icons on the front page, I will be working with the engineers on this after they come back from their Chinese New Year holiday break. I will keep you guys updated.
 

·
Registered
Joined
·
181 Posts
John, it's good to know that you're enjoying your new unit. We have a forum member here who's working on an add on device that will start the boot time as soon as you unlock the car/open the door. I think he also mentioned that it will keep the unit powered after you shut down the vehicle until you open a door.

As far as changing or moving the icons on the front page, I will be working with the engineers on this after they come back from their Chinese New Year holiday break. I will keep you guys updated.
That would be awesome.
 

·
Registered
2014 Vogue Silver with 22" wheels
Joined
·
3 Posts
Great Video Ray - my unit initially auto-connected to AirPlay CarPlay when I started the car just like in your video - but in the past week or so, it's stopped doing that. I've forgotten the AutoPlay box in wifi and bluetooth settings on my phone and re-paired...but still not auto-connecting.
I've noticed that choosing "Wireless CarPlay" on the AutoPlay settings doesn't stick - it seems to default to "CarPlay" the next time I open AutoPlay...

I must have changed a setting somewhere but not sure where...any ideas?

Cheers
John
 

·
Premium Member
2016.5 L405 HSE & 2020.5 L663 P400HSE
Joined
·
1,084 Posts
Discussion Starter · #420 ·
Great Video Ray - my unit initially auto-connected to AirPlay CarPlay when I started the car just like in your video - but in the past week or so, it's stopped doing that. I've forgotten the AutoPlay box in wifi and bluetooth settings on my phone and re-paired...but still not auto-connecting.
I've noticed that choosing "Wireless CarPlay" on the AutoPlay settings doesn't stick - it seems to default to "CarPlay" the next time I open AutoPlay...

I must have changed a setting somewhere but not sure where...any ideas?

Cheers
John
Try deleting the CarPlay device from your iPhone...settings-general-CarPlay-AutoPlay-Forget This Car...then pair again

You also have to have the connection mode set to Automatic in the AutoPlay app settings.
 
401 - 420 of 444 Posts
Top