RangeRovers.net Forum banner

61 - 80 of 100 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter #61
Hey guys, just an update on my shipment that should arrive in a couple days. I will have only 3 Capacitive units for the L494 RR Sport in this shipment. Please check my website on Wednesday evening to get yours before they are sold out. It will probably be another week or 2 before another shipment arrives.
 

·
Registered
Joined
·
1 Posts
Hi guys, has anyone had the issue where after installation you can’t switch to OEM mode and if so what the issue was?

I can hear the radio playing, however can not switch from android interface to original? Same for reverse cam...it doesn’t show despite following set up instruction....

Any help would be great...
 

·
Registered
Joined
·
594 Posts
Discussion Starter #63
Hi guys, has anyone had the issue where after installation you can’t switch to OEM mode and if so what the issue was?

I can hear the radio playing, however can not switch from android interface to original? Same for reverse cam...it doesn’t show despite following set up instruction....

Any help would be great...
I think it's important to note on this forum that this unit was not purchased from me. However, I will do my best to help you with your issues. If all else fails, I will be glad to sell you one of my units. I have sent you a PM...
 

·
Registered
Joined
·
594 Posts
Discussion Starter #64
Hey guys, just an update on my shipment that should arrive in a couple days. I will have only 3 Capacitive units for the L494 RR Sport in this shipment. Please check my website on Wednesday evening to get yours before they are sold out. It will probably be another week or 2 before another shipment arrives.
L494 Capacitive units already sold out...I have another shipment arriving in about 1 week.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #65
New shipment arriving tomorrow...for those that missed out on the last units.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #66
L494 Capacitive units are now in stock...
 

·
Registered
Joined
·
594 Posts
Discussion Starter #67
Updated to iOS 13 beta last night and running the new Apple car play. Definitely an improvement.

I’m going to try hardwired just because I like the fact of it charging my phone.
In the L405 forums j saw mention of the self parking feature not working anymore and I think I can confirm this.

its there on the button packs in style 2 but doesn’t activate anything on the dash.Not really a problem for me since I think I’ve used that feature once and it was to show someone how I’d probably never use it haha.
I'm working with the supplier on getting the self parking feature working. It seems that their test vehicle didn't have this option so it was overlooked by the engineers. I will keep you guys updated for those that actually have this feature and still want it to work with the new Android unit.
 

·
Registered
Joined
·
46 Posts
Love the unit! Totally recommend it to anyone who wants to refresh.

I look forward to getting the self parking function back.

Another thing that would be great would be the ability to adjust the daytime and nighttime (headlights on) screen brightness independently. I would like the screen at 100 percent during the day but then at night it does not dim down enough. If i set the day brightness lower, it is hard to see during the day but at night it is perfect. Should be a pretty easy change for the engineers I would think - just adding a menu option
 

·
Registered
Joined
·
181 Posts
Love the unit! Totally recommend it to anyone who wants to refresh.

I look forward to getting the self parking function back.

Another thing that would be great would be the ability to adjust the daytime and nighttime (headlights on) screen brightness independently. I would like the screen at 100 percent during the day but then at night it does not dim down enough. If i set the day brightness lower, it is hard to see during the day but at night it is perfect. Should be a pretty easy change for the engineers I would think - just adding a menu option
I concur on the screen brightness.
Mines set to 35 because it makes my retinas feel like exploding at night with anything over.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #70
On the screen brightness, I just go to the setup menu and change it to 0-25 for night driving and I set it to 75-100 for daytime driving. Anything above 25 is too bright for night driving in my opinion. It only takes a few seconds to access that menu and change the brightness.
 

·
Registered
Joined
·
46 Posts
But the unit does have the functionality of auto dimming. Assuming the company you are working with is willing to take input and issue updates I think not having to do that manually would be a major benefit and from a programming perspective very simple. Seems like they are dimming by a percentage of the daytime brightness setting. They could easily dim to a user defined variable and even maintain the same UI.
Are they planning to do updates or is this kind of a non updatable one and done thing?
 

·
Registered
Joined
·
594 Posts
Discussion Starter #72 (Edited)
But the unit does have the functionality of auto dimming. Assuming the company you are working with is willing to take input and issue updates I think not having to do that manually would be a major benefit and from a programming perspective very simple. Seems like they are dimming by a percentage of the daytime brightness setting. They could easily dim to a user defined variable and even maintain the same UI.
Are they planning to do updates or is this kind of a non updatable one and done thing?
I was told by the supplier that the software can not be updated on this current unit. However, they do take whatever input that I give them from customers and I was told that they are now working on a new project. He said that the new project will take some time and will cost more if we want everything to be perfect because the Range Rover has a difficult system to work with from the start. Anyway, I will keep you guys updated on whatever news I get from the supplier.
 

·
Registered
Joined
·
31 Posts
I’ve been remiss in writing up a quick review of the unit and my install.

First of all, Ray was fantastic to work with. I had a bit of issue with my first unit and Ray did all the right things you want a vendor to do (but they often don’t). He responded quickly, sorted the issue with his supplier and had a new unit out to me within a few days.

The install was fairly easy. First time in I had it done in just under three hours. Next time was much faster... easily less than 1.5 hours from start to finish.

All in all, the unit is a huge improvement over the stock system. I’m using Apple CarPlay and... well, it just works like it should. Also, I’ve noticed an improvement in sound quality from my Meridian system... I was never thrilled with the sound out of the 19 speaker Meridian system, but whether streaming or through the audio from my phone, it is noticeably improved, which is a bit of a surprise.

There are a few niggles that are bothersome, that I do hope the supplier can fix. They are, in order of concern from my perspective:
1. HVAC controls are too dim during the day. I believe the light sensor is on one of the switch packs, which are now tucked away in the dash.
2. Auto dim screen at night. It’s retina scaring at night. You can jump into the settings and lower it manually fairly easily, but it really should auto dim to an acceptable level based upon ambient light without menu surfing while driving.
3. Volume will sometimes lower - totally random and seems to happen more on my wife’s phone than mine. This could be a CarPlay issue. And it was mentioned that if you close open apps on the iPhone it can help (yet to verify).
4. Auto-assist parking no longer functions. While I would like it to work, it’s not a big one for me as I never use it.

I do want to add that overall I’m very happy with my unit and wouldn’t ever consider pulling it out due to the items above... they are minor compared to the overall improvement to the screen and system.

Thanks again to Ray for his excellent support.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #74
jettlag, thanks for posting your review. I really think this Android unit is the best upgrade/modification that I've made to my L405 Range Rover since I've owned it. The 2013-2016 Range Rovers are in serious need of this unit and unfortunately some are missing out on how great it is due to it not being so called perfect. I'm almost sure that if this unit was without flaws then it would cost twice as much if not more.
 

·
Registered
Joined
·
594 Posts
Discussion Starter #75
Update: My supplier just informed me that they decided not to produce another cable to enable the automated park assist because it would cost too much. However, he sent me a video on how you should connect the wiring to enable the feature. He said that it is a real simple connection. I don't have the automated park assist so I can't test this to see if it works. Anyone interested in the video, please send me a text and I will forward it to you...
 

·
Registered
Joined
·
594 Posts
Discussion Starter #76
Update: Courtesy of forum member pherplexed...


 

·
Registered
Joined
·
7 Posts
I'm checking the car into Landrover on Monday for a Park Sensor disconnect issue. (LR issue, not the Android head) They'll connect the LR computer while I wait to fix. I'm going to ask the techie if it's possible to digitally disconnect the light sensors on the switch packs. No harm in asking. I'll let you know what he says. Everything else in the car is digitally switched. Can't see why that can't be turned off.
 

·
Registered
Joined
·
7 Posts
Does anyone know what all the menu items in the lower half of the Settings page of the AutoPlay app actually do? I've switched them on and off and they seem to do anything as far as I can tell. The Mandarin English may be to blame. I'm sure they must do something.
 

·
Registered
Joined
·
40 Posts
Has anyone installed this yet in a 2015 RR Sport and have all or any issues sorted out? Also has anyone updated the cameras (rearview) as well?
 

·
Registered
Joined
·
594 Posts
Discussion Starter #80
Does anyone know what all the menu items in the lower half of the Settings page of the AutoPlay app actually do? I've switched them on and off and they seem to do anything as far as I can tell. The Mandarin English may be to blame. I'm sure they must do something.
I agree, some of the menu items in the AutoPlay App don't seem to do anything. I'll keep playing around with mine whenever I have time and I will update you guys if I notice anything worth mentioning.
 
61 - 80 of 100 Posts
Top