RangeRovers.net Forum banner

1 - 12 of 12 Posts

·
Registered
2008 Range Rover Sport HSE
Joined
·
3 Posts
Discussion Starter #1
I have exhausted all of my known options, read the threads and cannot find why I am continuing to have P0171 and P0174. I have replaced the intake plenum gasket, MAF, spark plugs, air filter, EGR, brake booster, PCV and found no vacuum leaks after smoke testing at home. I have also replaced the thermostat housing, thermostat and a new temperature sensor. Sometimes I get an error indicating P0116 but after restart it clears. Prior to replacing all of that I had 6 codes in the system, P0102, P0113, P0101, P0171, P0174 and P0506. After replacement and fuel trim reset, I am continuing to receive the dreaded P0171 and P0174. I do hear what seems to be a hissing from the passenger side of the engine compartment around the PCV but there are no apparent leaks after smoking the engine.
Help Help Help!

2008 Range Rover Sport HSE 136000 miles Buckingham Blue
 

Attachments

·
Registered
Joined
·
12 Posts
I have exhausted all of my known options, read the threads and cannot find why I am continuing to have P0171 and P0174. I have replaced the intake plenum gasket, MAF, spark plugs, air filter, EGR, brake booster, PCV and found no vacuum leaks after smoke testing at home. I have also replaced the thermostat housing, thermostat and a new temperature sensor. Sometimes I get an error indicating P0116 but after restart it clears. Prior to replacing all of that I had 6 codes in the system, P0102, P0113, P0101, P0171, P0174 and P0506. After replacement and fuel trim reset, I am continuing to receive the dreaded P0171 and P0174. I do hear what seems to be a hissing from the passenger side of the engine compartment around the PCV but there are no apparent leaks after smoking the engine.
Help Help Help!

2008 Range Rover Sport HSE 136000 miles Buckingham Blue
I am going to plus 1 bc i have been battling this very same thing for half a year now and its getting ridiculous
 

·
Registered
Joined
·
640 Posts
I have exhausted all of my known options, read the threads and cannot find why I am continuing to have P0171 and P0174. I have replaced the intake plenum gasket, MAF, spark plugs, air filter, EGR, brake booster, PCV and found no vacuum leaks after smoke testing at home. I have also replaced the thermostat housing, thermostat and a new temperature sensor. Sometimes I get an error indicating P0116 but after restart it clears. Prior to replacing all of that I had 6 codes in the system, P0102, P0113, P0101, P0171, P0174 and P0506. After replacement and fuel trim reset, I am continuing to receive the dreaded P0171 and P0174. I do hear what seems to be a hissing from the passenger side of the engine compartment around the PCV but there are no apparent leaks after smoking the engine.
Help Help Help!

2008 Range Rover Sport HSE 136000 miles Buckingham Blue
Have you replaced O2 sensors AFTER fixing the other issues?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
119 Posts
My 07 hse 118k, has exactly same codes for last 2 months, sometimes check engine light go away on his own for a day or two
And if i clear the codes myself, check engine light back after driving about 15 miles
Car performs exactly the same with the codes, and mpg the same as before too

Cleaned maf sensor (it was dirty), with the spray can, erase the code, but came back quick

Maf sensor are under $50 on ebay, one of these days gonna buy to see if fix the codes
Did a quick research and lean on both banks, big chance its related to a sensor
 

·
Registered
2008 Range Rover Sport HSE
Joined
·
3 Posts
Discussion Starter #5
Have you replaced O2 sensors AFTER fixing the other issues?


Sent from my iPhone using Tapatalk
I have not. I checked to voltages and I am seeing
Have you replaced O2 sensors AFTER fixing the other issues?


Sent from my iPhone using Tapatalk
I have not. The data from the OBD appears to show good information from the O2s. This all started after a coolant leak and I had to replace the intake manifold gasket and plenum gasket. I guess it would not hurt to change the sensors based on mileage... Could it be a bad coolant temperature sensor?
 

·
Registered
2006-2009 Range Rover MkIII / L322 (Sold), 2005 Land Rover LR3/ L319
Joined
·
54 Posts
Gentlemen, good day. I answered this query from a another enthusiast not too long ago and was able to relieve him of this headache. I, too, had this persistent problem that almost had me throwing money into replacing parts that were actually in good working order. After countless hours of research in various LR forums, I was able to trace that the problem is that these rigs are trying to be so smart, that they keep all the error and fault codes stored deep in the bowels of their ECU memory. Some instances, even though you have replaced the "faulty"part and cleared the codes, it throws you the same error codes over and over again. The reason being is that it "Learned" the error code and kept it in it's adaptation memory. Adaptation is the way the ECU memorizes what the vehicle is doing everytime you drive it, INCLUDING how you drive the vehicle. It keeps reverting back to the error it learned and will throw it out at you time and time again. Long story short (sorry) find an indy that has a diagnostic tool that can clear the adaptation values of the engine so that the ECU can now re-learn adaptations free of faulty parts. Hope this helps
 

·
Registered
Joined
·
12 Posts
Gentlemen, good day. I answered this query from a another enthusiast not too long ago and was able to relieve him of this headache. I, too, had this persistent problem that almost had me throwing money into replacing parts that were actually in good working order. After countless hours of research in various LR forums, I was able to trace that the problem is that these rigs are trying to be so smart, that they keep all the error and fault codes stored deep in the bowels of their ECU memory. Some instances, even though you have replaced the "faulty"part and cleared the codes, it throws you the same error codes over and over again. The reason being is that it "Learned" the error code and kept it in it's adaptation memory. Adaptation is the way the ECU memorizes what the vehicle is doing everytime you drive it, INCLUDING how you drive the vehicle. It keeps reverting back to the error it learned and will throw it out at you time and time again. Long story short (sorry) find an indy that has a diagnostic tool that can clear the adaptation values of the engine so that the ECU can now re-learn adaptations free of faulty parts. Hope this helps
I purchased a mongoose cable so I will try to hook it up and see if I can clear the ecu adaptation values with it. (a member from this community who addressed this very same issue recommended to do so because it is the very same cable used at the dealership)
Thank you for this response tho, I greatly appreciate it! Hopes this helps my troubles with these darn codes
 

·
Registered
2008 Range Rover Sport HSE
Joined
·
3 Posts
Discussion Starter #8
Prison Mike, please let me know if that works... If so, I'll be looking for the mongoose cable and software.
 

·
Registered
Joined
·
119 Posts
Gentlemen, good day. I answered this query from a another enthusiast not too long ago and was able to relieve him of this headache. I, too, had this persistent problem that almost had me throwing money into replacing parts that were actually in good working order. After countless hours of research in various LR forums, I was able to trace that the problem is that these rigs are trying to be so smart, that they keep all the error and fault codes stored deep in the bowels of their ECU memory. Some instances, even though you have replaced the "faulty"part and cleared the codes, it throws you the same error codes over and over again. The reason being is that it "Learned" the error code and kept it in it's adaptation memory. Adaptation is the way the ECU memorizes what the vehicle is doing everytime you drive it, INCLUDING how you drive the vehicle. It keeps reverting back to the error it learned and will throw it out at you time and time again. Long story short (sorry) find an indy that has a diagnostic tool that can clear the adaptation values of the engine so that the ECU can now re-learn adaptations free of faulty parts. Hope this helps
In my case clearing the codes & adaptation don't solve the problem, i used my 4d can software.
Codes came back after driving about 10 miles
I have done it more than once

I have a vacuum leak, or something else not working properly !!
 

·
Registered
Joined
·
119 Posts
Yesterday sprayed throttle body cleaner everywhere, vacuum hoses, brake booster, throttle body, all over the engine
Rpms did not react
 

·
Registered
2007 Range Rover Sport SC L320
Joined
·
120 Posts
Does your car accelerate normally under load/when you give it gas?

If one of the solutions or diagnosis outlined for your CEL Codes involve the fuel system, it could be a worn/bad fuel pump. Have you checked the Fuel Pressure?

The hissing is definitely a concern and could point to the problem - just keep looking for it. Maybe the PCV is not working properly as well?
 

·
Registered
2006-2009 Range Rover MkIII / L322 (Sold), 2005 Land Rover LR3/ L319
Joined
·
54 Posts
Yesterday sprayed throttle body cleaner everywhere, vacuum hoses, brake booster, throttle body, all over the engine
Rpms did not react
I don't know if you were able to solve this issue but it seems that if the codes come back after driving for about 10 miles, the problem happens after the engine warms up or vibration from the road. Sorry that clearing the adaptation solution did not work for you. If it is an intermittent vacuum leak, there must be a loose clamp or kinked hose somewhere.
 
1 - 12 of 12 Posts
Top