Range Rovers Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys! So I picked up an 06 with 29k on it for dirt cheap... Thing is a beauty. No issues, lights weren't on. Brought it home, decided to try and adjust the ride height using the controls.. idk why I didn't do this at the dealer, but I didn't. Dropped it down and boom... 5 minutes later the light kicked on. I have a warranty for 80k, so it will be fixed regardless, I was just wondering if anyone had an idea of what I might be looking at?

Thanks!
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,015 Posts
I don't see how the two things could be related honestly, most likely just a coincidence. If you had a suspensions problem you'd get a suspensions fault of some sort, not a CEL. Those are usually emissions related (could be as simple as you not tightening the gas cap during your last fill-up?) I assume your suspensions came back up normally after you dropped them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for the reply. I did fasten it, I double checked just now to be sure. The ride height did work perfectly, yes. Just amazing that it happened 5 minutes after I hit it. So what is my best option here? Take it to a dealer and have the code examined?
 

·
Premium Member
Joined
·
2,467 Posts
I would go back to whatever dealer you bought it from and let them see why the light came on. Ask for the fault codes that were stored despite what they say it is, or if they just clear it.

Most extended warranties don't cover anything for the first 30-60 days, as they consider that pre-existing, but it could be something very simple too.
 
1 - 4 of 4 Posts
Top