RangeRovers.net Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, I just bought a 06 RR just to join this forum ;-)
I do not have the GPS manual. So pls bear with me. My problem is that I see a red line crossed over the GPS logo on the navigation screen. My navigation seems working but it just does not know where the car is located. I have to manually calibrate the location once a week or so. Would you know how to fix this?
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
Sounds like a bad antenna connection to me... If you have the Denso touchscreen system (you should if you have a 2006), run diagnostics and you should find out what type of GPS signal you are receiving. See this document: download/file.php?id=4611
 

·
Registered
Joined
·
8 Posts
Well, I took the bull by the horns and today bought a new genuine GPS antenna. It sorted the problem. I also fitted the 2011/2012 disc. A couple of nice little extras on there that I didn't know about. I was getting very close to ordering the dvd drive unit! Glad the antenna sorted it. :)
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
10 Posts
Kev. How much did the Genuine GPS Cost? and is it built in to the Roof Hump, or how is it fitted? Is it a Dual Antenna, with Cellular as well?
 

·
Registered
Joined
·
8 Posts
Kev. How much did the Genuine GPS Cost? and is it built in to the Roof Hump, or how is it fitted? Is it a Dual Antenna, with Cellular as well?
Hi, it cost me about £70 +vat . (£84ish) It is dual. You just drop the rear headlining slighty and remove 2 10mm spanner sized nuts. Interestingly, mine looked like it had been leaking water in slightly around the nuts. The threads were rusty. It takes about 10 minutes to fit. Kev.
 

·
Registered
Joined
·
8 Posts
049.jpg 056.jpg I thought it might be helpful to show what the GPS signal was showing before and after fitting the new antenna. First image is before. Initially I thought all was ok, as it was showing readings. But noticed that the id and date etc was missing. Fitted the antenna and the second shot shows what it is now showing. System working fine now.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
38 Posts
Well, I took the bull by the horns and today bought a new genuine GPS antenna. It sorted the problem. I also fitted the 2011/2012 disc. A couple of nice little extras on there that I didn't know about. I was getting very close to ordering the dvd drive unit! Glad the antenna sorted it. :)
Kevshore
If you don't mind me asking was the sat nav disc a genuine landrover part as I have bought one too and find it lacking in coverage. Mine is a genuine part costing £169.00.
Attie
 

·
Registered
Joined
·
8 Posts
It was. My old one was 2007. I've yet to see any difference with regards to coverage. Can you give me an example? I will have a look.
 

·
Registered
Joined
·
5 Posts
I have the same issue, 07 sport and when on motorway recently gps went off and I'm currently off road in the North Sea!! Tried a fakra connection gps antenna off eBay but still got the red line through the gps icon and still in North Sea. Do I need to reset anything or should it work when I plugged the gps antenna in? I plugged it straight to the back of the drive under the seat just to try it out.

And does anyone know my next port of call before I bite the bullet and buy a dvd drive??

Regards
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
248 Posts
I think the North Sea may exceed the maximum wading depth of the Range Rover. The salty water may be causing you some electrical problems.



Have you tried disconnecting the battery and reconnecting it? The GPS on my MKIV unit had stopped working after I had disconnected the antenna to reroute the cable and couldnt figure out what was wrong. A few days later I had to disconnect the battery for other reasons and later found out that the GPS was working again.
 

·
Registered
Joined
·
5 Posts
That's not the only problem the wife is in Norway following it the 'fastest route' home! And no but thanks for the tip I'll try it and let you know how I get on.
 

·
Registered
Joined
·
5 Posts
It's died again, roughly same spot same motorway. Anyway it's still got the red line after the hard reset (battery off) does anyone know of a repairer? I'm assuming it's the GPS receiver in the unit itself??
Many thanks
 

·
Registered
Joined
·
3 Posts
Hi there,
I wonder if someone could please offer some guidance. I am also having the same problem with GPS on 06 RR Vogue.
Can anyone who has changed this antenna tell me where does the wire from the GPS antenna ends up? Does it go the red amplifier as shown in the attached picture or does it go straight to the DVD drive?
I have attached a picture of what people often refer to as GPS amplifier and I want to know if the wire from the antenna comes to this amplifier? This is so that I can connect a replacement antenna and check if indeed my GPS antenna is faulty before opening the roof lining?
Thanks and Regards
GPS-RR.jpg
 
1 - 17 of 17 Posts
Top