RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Over the past few months, my suspension fault light would come on with a little chime and an amber light on my dash. In the center it reads “SUSPENSION FAULT NORMAL HEIGHT ONLY”. It used to only do it when it was cold. Now it does it almost every time i drive. If I turn the engine off then back on, the suspension would indeed work. But after a minute of driving it’d come right back on. Heck, if I’m parked at an angle, I can feel the truck level itself. All while the light is on.
Have not gotten it scaned yet. Anybody have the same issue? I’m leaning towards a new compressor. I’ve noticed the rate of raising the truck isn’t as swift as it was.

any input is appreciated!
 

·
Registered
Joined
·
806 Posts
I had it and changed my drier and that didn't fix it. Then I rebuilt the compressor and that didn't fix it. Finally I changed my compressor to an after market one off ebay and that fixed the problem. I think the problem may be a crack in the plastic plate . It happens between the two hose couplings and is almost invisible. I didn't want to change that and find it still didn't work so I sprung the $200 or so and changed the whole thing.
 

·
Registered
Joined
·
2 Posts
Yep had it with mine compressor knackered change the whole unit and put a new relay in at the same time if you get the Hitachi one it comes with a new relay
 

·
Registered
Joined
·
1 Posts
hi I have a 2012 RRSport and after mot my amber light came on ,the suspension works well in all settings but the screen does not show the wheel articulation for any wheel ,my garage checked it said on pc read out rear height sensor he took it off and said it worked untill I collected the car and failed again,still checking it could be height sensor fault or the link wire.do you know why non of my wheels shows on the screen as suspension seems to work fine .after parking the rear seems to set lower than access height cheers simon
 

·
Registered
Joined
·
144 Posts
I know some of you are worried about these pumps, but the parts exist for complete rebuilds. Its just a basic pump, no magic, swap everything, it is not expensive. Or go blow a wad on the ‘new design’.
 

·
Registered
Joined
·
106 Posts
I've had my "Suspension Fault" warning light come on a couple of times now but unaccompanied by any qualifier such as "Normal Height Only". After the light came on, I ran the suspension through all of the programs with all 3 height options and found everything working as advertised. I even did an OBDC check but no codes were displayed.
 
1 - 10 of 10 Posts
Top