RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
121 Posts
Discussion Starter #1
Just picked up my 2010 Stornaway / Ebony RRS HSE LUX and on the Touch Screen, my Verizon Wireless Blackberry Tour 9630 show up as "rizon Wireless", C'mon LandRover give me a "V", give me an "e", give me an "r".

She is going back in today to deal with;
  • 1) Temperature display issue (keeps on reverting back to Celsius)
    2) The backup camera picture is grainy and yellow hued and the lines don’t swing
    3) “rizon Wireless” issue on the touch screen
    4) The IPOD sound is very low
As my sport has a date code of 08/09 (on the door), maybe I will get the new and improved beta Ver 1.000001 (?) software to fix these little niggles.

Issues aside, My new 2010 is exponentially better than my 2006, the power is amazing, the ride quality is vastly improved, the new interior is just voluptuous with the stainless steel accents on black leather, and the $1,000 chump change I spent on the Extended Leather Pack gives ambiance to the interior that I was not expecting.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
acole10000 said:
2) The backup camera picture is grainy and yellow hued and the lines don’t swing
BTW, don't know about picture quality, but I recall reading on the Disco4 forum in the UK that the yellow lines do not "swing" on the backup cam, unless you have the optional (more chump change...) surround camera system. :doh: Makes no sense to me (why even bother putting directional lines there then?), and hopefully I just misread that thread.

Too bad your manufacture date is 8/9. As of 9/9 production, I believe the 5" TFT display in the instrument cluster should also display turn-by-turn directions from the satnav (duplicating those on the touchscreen display) and MP3 track info, according to LR documentation.


 

·
Registered
2010-2012 Range Rover Sport
Joined
·
121 Posts
Discussion Starter #4
Too bad your manufacture date is 8/9. As of 9/9 production, I believe the 5" TFT display in the instrument cluster should also display turn-by-turn directions from the satnav (duplicating those on the touchscreen display) and MP3 track info, according to LR documentation.
Referencing the above post, I was at the dealer this morning and the service manager and I drove a 10/9 car and no turn by turn in the center display, Again had I spent the chump change and I would have got the turn by turn option.
 

·
Registered
Joined
·
36 Posts
acole10000 said:
Too bad your manufacture date is 8/9. As of 9/9 production, I believe the 5" TFT display in the instrument cluster should also display turn-by-turn directions from the satnav (duplicating those on the touchscreen display) and MP3 track info, according to LR documentation.
Referencing the above post, I was at the dealer this morning and the service manager and I drove a 10/9 car and no turn by turn in the center display, Again had I spent the chump change and I would have got the turn by turn option.
Will attest to the fact that my MY2010 RRS LUX, MFG date 09/09 does not have the turn by turn. I have not tried an MP3 CD yet, so cannot comment on track info. I do have an iPod Touch plugged and it would be nice to display track info from that source, but nada. It does show the terrain selector switch... which, although neat, is not as useful (in my mind) as having the turn by turn display feature.

I am hoping all that is required is a software update to provide the functionality. I have an appointment next week to bring my vehicle in to have them address a series of electical / software related annoyances so will attempt to get some G2 on turn by turn updates.
 

·
Registered
Joined
·
32 Posts
My 2010 Sport S/C has the same exact issues: Temp display keeps reverting back to Celsius after the ignition is off for a lengthy period and "rizon Wireless" as well.
Did you get it fixed? We just bought ours 3 days ago and took it to the service center immediately for a checkup before driving home and they said there were no TSB's or recalls, or anything. Hmmmmm....
 

·
Registered
Joined
·
32 Posts
Just an update: we took our 2010 RRS SC in today and they said they will get LR to send a software fix for the Celsius issue. We forgot to ask about the "rizon Wireless" - will send our service guy an email to tack on that fix too.
Our Sport is in service for a few days - getting a few minor things corrected. No big deal.
 

·
Registered
Joined
·
96 Posts
acole10000 said:
She is going back in today to deal with;
  • 4) The IPOD sound is very low
[/i]
If your using an AUX plug to connect your iPod try turning the volume on your stereo all the way down first, then turn the iPod volume all the way up, then turn your stereo volume back up to where you want it and use the stereo to control the volume. If your using USB connection then this won't work though.
 
1 - 8 of 8 Posts
Top