Range Rovers Forum banner
worse
1-7 of 7 Results
  1. Range Rover Mark II / P38
    Hi Guys, Hopefully you can give me some help and guidance. Up until yesterday, my 1999 4.0 P38 was running very well.....apart from a small coolant leak that was coming from the thermostat housing. I ordered a replacement housing, and yesterday swapped it over. Drained from the bottom of the...
  2. Range Rover Evoque / L538
    I have just acquired a 2014 Pure Plus that has already had its first service (just last month). While checking the car all over, I noticed that the front tires have between 1.5mm and 2mm more wear than the back tires. The car has just over 20,000 km on it. I would have assumed that the tires...
  3. Range Rover Mark II / P38
    Ok, whilst working through a small list of things to change, next on my list this morning was a new set of HT leads. Did the dark test and I could see at least two leads arcing, so time to change. The engine has been running and idling very smoothly, but around 1500-2000 revs it has be in been...
  4. Range Rover Classic
    I'm having some rough idle and stalling, mostly on startup. So I replaced the stepper motor with a part from a local O'Reilly. Now it runs worse! The idle seems a bit lower so it is stalling all the time now at stops. Is there a way to adjust the stepper motor? Or did I just get a bad one from...
  5. Range Rover Mark III / L322
    Hi, Recently bought immaculate vogue v8 with superb full dealer service history and stormer body and wheels. Love it so much but has got to point scared to drive incase another gremlin shows its face. On average for every 2 or 3 times i drive a new prob occurs. All started when getting used to...
  6. Range Rover Mark III / L322
    Arnott air bags fail in cold weather - customer service is horrible Did any one else have a similar experience? In November I bought a new-to-me '05 HSE. It is an Arizona car purchased via eBay (12th rover bought from eBay) from a dealer in Memphis. I live in New Hampshire. When I bought...
  7. Range Rover Sport / L320
    I know I've made a thread about this in the past, but it's really puzzling to me that I can't find out much more info about this problem. My experience with Land Rovers (ie. my Discovery II) was that they're VERY consistent with their issues. This has been my case with every problem I've ever...
1-7 of 7 Results
Top