RangeRovers.net Forum banner

won't start

  1. 92 Classic Won't Start

    Range Rover Classic
    Ok so I am really looking for some new insight because I'm almost at a loss on what the problem is here. I've searched through the forums but I think that I am overlooking something and want to detail everything that I have done and tested and try to get a fresh set of eyes on this problem...
  2. Key Won't Turn, Fuse #39 keeps blowing out

    Range Rover Mark III / L322
    Thanks in advance for any help or advice with this. The car is a 2004 RR HSE with approx 155k miles. The key goes in the ignition, unlocks the car, turns, but will not turn over. It keeps blowing out fuse #39. I have tried removing #18 to reset Immobilizer ECU, but it doesn't help. For a...
  3. 2013 RR sport HSE won't start, check engine & transmission fault messages

    Range Rover Sport / L320
    2013 RR sport HSE won't start, check engine & transmission fault messages my closest RR dealer is 85 miles away. yesterday my car wouldn't start...no warning ahead of time...seemed to be battery although couldn't imagine why it would be dead. had it jumped, drove it all of yesterday & it ran...
  4. Range Rover Vogue Message Centre

    Range Rover Mark III / L322
    Hi all, My Range Rover Vogue, has suddenly stopped working! I left my vehicle standing for about three weeks and when I returned to it the central locking wouldn't respond, strange I thought and assumed that it was the battery, I put the battery on a charger and no it was fine. Refitted the...
  5. Battery went flat, car won't start, dash doesn't display anything

    Range Rover Mark II / P38
    Battery went flat, car won't start, dash doesn't display anything Hey guys, So I have a 1996 RR P38 4.6 HSE The problem is my battery went flat, and now even with jumper cables attached, the dash doesn't light up at all and I can't start the car. The lead up to this was as follows: •...
  6. Car won't start ... temp gauge stuck on red ... a mystery to solve.

    Range Rover Mark III / L322
    Car won't start ... temp gauge stuck on red ... a mystery to solve. Hi guys I hope someone out there can shed some light on this. Background: 2003 Range Rover with 156,000 well looked after miles. Having just spent a week up in the snow driving around 1000 trouble free miles I am on the way...
  7. 95 Rover 4.0 SE NOT starting, but Cranking

    Range Rover Mark II / P38
    So I have a 95 Range Rover SE 4.0. When I bought it there were a few problems with it, I did the standard oil change and ran engine flush through it first (of course), also replaced the fuel filter. Then I took it out for a ride to see what she could do. Came back home NO problem, however the...
  8. 4.6 started lovely 3 days ago now just coughs! HELP!!

    Range Rover Mark II / P38
    M reg p38 4.6 ran sweet as a nut on petrol and gas now will not start no matter what i try! Fuel pressure is good and spark is good, new leads and plugs, new maf, and fuel filters only weeks ago. It will spin over and backfire through the air intake, smoke making its way out of the exhaust also...
Top