Range Rovers Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-15 of 294 Results
  1. Range Rover Mark III / L322
    I have searched ad nausem. The RAVE manual link is dead. Google comes up with rubbish. After 5 hours I am *literally nauseous. I need this quickly solved as I don't have time to wait, nor inclination to pay the $600 for a factory harness. I have a UHAUL harness hooked up and it works...
  2. Range Rover Mark III / L322
    My 2004 RR L322 just died on me in France. Apparently the wiring loom is burned out, so I'm looking for someone (or a garage) to help me get it back and/or rewire it. Know anyone?
  3. Range Rover Mark II / P38
    new here hi all- hoping some poor bugger has had same problem 95 p38 been towing hired trailer that had short in parkers. now i have no LH parkers front or back is not globes -have no power can anybody tell me where power comes from or how to trace problem i have donor vehicle but dont know...
  4. Range Rover Mark III / L322
    Hi. am searching for the extra relay that follows trailer wiring kits . Is a 40a relay that you have to put in socket rear of car .
  5. Range Rover Sport II / L494
    I am having problems with the running lights (tail lights) not working on my trailer. The pin on the wiring plug has no power to it. The turn signals and brake lights work normal. I did find a blown fuse #27 (Trailer side lights) in the passenger compartment Fuse block. I replaced the 10A...
  6. Range Rover Classic
    This is out of a 1993 RRC. Please help me figure this out. After spending several hours on my truck trying to diagnosed why it won't start I realized this wire may be the offender. The wire with the black connector and red dot was loose/broken from the end and came right out. Now, this is my...
  7. Range Rover Classic
    Hi guys, I recently bought a 1990 3.9 project car. The previous owner had replaced the ignition system with a crane cams cd ignition box and coil, which has failed. I have just pulled the old system and replaced it with a new distributor (old one was shot,) ignition switch, neutral safety...
  8. Range Rover Mark III / L322
    Hi I've bought a 2012 Range Rover and I've got a problem with my parking sensors. Basically it makes a noise, flashes then goes off so I cannot listen to the sensors to find out what one has the issue. I've got the Hawkeye diagnostics but I cannot read the fault codes without the black...
  9. Range Rover Mark III / L322
    We are back to the trans overheat messages and theh are more frequent and seem totally random. I have to check the resistance value of temp sensor but not sure if it will give me a clue as the fault comes intermittently. I am asking if the harness from a bmw, say 2002 x5 ,would be the same as...
  10. Range Rover Sport / L320
    Are there any diagrams or pictures available that show the installation of the wiring associated with a trailer hitch on a 2012 Range Rover Sport. It looks like the part # ( VPLST0072 ) is specific to model years 2012-2013. From the online pictures there appears to be only two connectors on the...
  11. Range Rover Sport II / L494
    Good afternoon, My left reverse light is no longer working. the bulb itself is not the issue and neither is the actual taillight. when reading the volts through the plug i get a reading of 1.27V while the right side is a 7.7v. Using the gap diagnostic tool i also get the fault which stated...
  12. Range Rover Classic
    So “some” idiot cut the wire harness on my truck years ago and lost the harness and I’m having difficulty finding resources on the colors and how they match to a modern stereo head unit. I’ll post some pics of what I’m working with and if anyone has any info I would be super grateful! I...
  13. Range Rover Sport / L320
    So I have a 11’ hse 5.0 gas. I smelt burning behind driver side a pillar and found that there was a connector burnt out under the side curtain air bag. I popped the cover and included a picture. I have no idea what this is. Just looks like it connects to almost like a piece of tape that goes to...
  14. Range Rover Classic
    I added an aftermarket stereo and am getting no sound. The receiver gets power and I can tell it receives music via Bluetooth. But no sound comes through the speakers. I’m confident I wired the speakers correctly. I did not connect the “powered antenna” wires to anything. Likewise, there were...
  15. Range Rover Mark III / L322
    Hi, my name is Tinca, I am writing you from Romania. I own an LR Range Rover Vogue, TDV8, 2011. I am working to a system which allows me to start the engine via SMS. The system is nearly ready, but we have encountered a problem: we need to trick the condition of press the break pedal when you...
1-15 of 294 Results
Top