Range Rovers Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Range Rover Mark II / P38
    Hello all, whilst driving yesterday my rover developed a strange rattle/tap that is only present during engine revs. I have been trying all day to fix but have had no luck. I do have an exhaust leak which I patched and I tried to remove the wrap / repatch which made no difference. I was also due...
  2. Range Rover Mark II / P38
    When I drive the Range Rover from cold the revs climb then flutter by about 500 rpm. When the engine is warm it’s all fine. I think it’s to do with a temp sensor but don’t know where to start. Anyone here know anything that might help? Thanks
  3. Range Rover Classic
    So in a previous thread I mentioned that the transmission has gone on my soft dash classic. The engine & transmission have come out and the gearbox is being sent away for refurb, I'm also replacing the transfer box at the same time. Whilst the engine is out we're going to do some work on that...
  4. Range Rover Sport / L320
    Red Airbag light, car tilted whilst parked and suspension fault Hi All I have the airbag light illuminated on my 2005 RRS for the last 4 days whilst driving and would like to know if there is any common faults which might be worth checking before sending it to the garage. I also have a...
  5. Range Rover Mark II / P38
    Hi There, I have a1997 Range Rover 4.6 HSE, which sometimes comes up with a EAS Failure -probably every few months. Last night the same thing happened, which I remediedby resetting it with the dongle into my laptop with the software I bought(along with the dongle) off ebay - which goes in under...
1-5 of 5 Results
Top