Range Rovers Forum banner
unusual

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-13 of 16 Results
  1. Range Rover Sport II / L494
    Hi everyone, I'm looking at a pre-owned RRS with ~42,000 miles (it appears to have been owned in the city, as opposed to suburb/rural) and what I initially believed was solid evidence of good ownership, in the form of a Carfax with extensive and frequent service records. Looking at it a second...
  2. Range Rover Sport / L320
    After an extended down time with my 2006 RR HSE and then a Strutmaster conversion and full brake job including sensors, I had a series of "Lights" giving me issues as well as symptoms. The Check Engine Light, ABS light, and the amber triangle were all on, the speedometer wasn't working, and the...
  3. Range Rover Mark II / P38
    I must have the cleanest diff casing in the south of England as I've cleaned it so many times to try and work out where the oil is coming from. I am now totally convinced that it is coming from the weld between the back plate and the axle casing. It doesn't seem to leak when the car is...
  4. Range Rover Mark II / P38
    I made a video of the noises: http://www.youtube.com/watch?v=p9ZX6nVdlgI The exhaust solenoid is acting weird I think. The last noise is the strangest. Other Issues related to EAS are. 1. Truck rear will raise when driving. 2. Whole truck will raise to wade height when driving. 3. Truck will...
  5. Range Rover Mark II / P38
    98 4.6 auto - really warm today so I used the fob to unlock and holding the button expected the windows to drop as usual - er no - the air suspension dropped a bit thinking it had simply settled to auto level i ppressed the unlock button again and again it lowered further and for a 3rd time...
  6. Range Rover Mark III / L322
    I was wondering if anyone had some insight on a humming noise that begins to occur at 55+ miles per hour or so on my newly acquired 2011 Range Rover HSE. Not sure if it's drive train related, wind noise or something else. It seems to be coming from the front somewhere near the dashboard...
  7. Range Rover Mark III / L322
    I had suspected the noise to be coming from the exhaust system at some point because when at idle, the noise would start and I would tap the accelerator and the noise would go away. I recently had my catalytic converters changed and the noise is still there at times. Now I feel as though the...
  8. Range Rover Mark II / P38
    When ever I move my transmission from drive or reverse into neutral the revs go up to almost 1000 revs and then take 4-5 seconds to slowly come down to normal again (about 750). I would expect the gems system to cut the revs instantly to compensate for the 'no load' situation - like other autos...
  9. Range Rover Classic
    Hi All. I have a 94 SWB. The CEL (not SES) came one while I was offroading last Saturday with a code 19. I reset it according to the procedures and drove another 200 miles without any issues or the CEL coming back. During the week, the CEL came on again. I went to look at the display and nothing...
  10. Range Rover Mark II / P38
    I've got some annoying EAS trouble, have seen something about this some time ago, but couldn't find it any more, tried to search and read tons of threads/posts, but didn't succeed. Most of the symptoms are: When I park the car in my driveway (sloping a little, parking the car with the rear...
  11. Range Rover Mark III / L322
    Unusual air suspension and park distance, misc. electrical problems My apologies in advance if there is something posted out here on this, I couldn't find it... I recently got the "Air Suspension Inactive" message on my 2005 HSE. I plugged in my RSW Solutions reset tool and got blue/green...
  12. Range Rover Mark II / P38
    Hi to all. I have a 1997 P38 4.6 HSE. It has a very annoying intermittent fault with the EAS that I just cant get to the bottom of. What happens from time to time is that ALL Four led's on the ride height select switch come on solidly together with the eas light on the dash but now here is the...
  13. Range Rover Mark II / P38
    Unusual heat distribution problem - not blend motors/flaps I think Hi, I have a heat distribution problem I haven't been able to find the answer to searching the forum. When starting, everything is ok with my heater. Heat comes on relatively quickly (good since I'm in cold Denmark). All heat...
1-13 of 16 Results
Top