Range Rovers Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. Range Rover Mark III / L322
    Ive had my 2006 Range Rove for several weeks now but I just came across this unplugged wire by the Battery, can anyone tell me what it is ? The PO just had the battery replaced so Im thinking they just forgot to plug this back in. I plunged it back in but can not tell any differences. Its in...
  2. Range Rover Sport / L320
    I was rummaging behind the glove box of my RRS 2010 to fix a rattle. I accidentally pulled the black and purple wire from its connector. I know it lit the interior lighting. I can't figure out where it was disconnected from. Any help greatly appreciated. Thanks
  3. Range Rover Classic
    Hi my 95 lwb ha this problem where the bat light only works when u unplug the rpm wire from back of alternator. Charging system is good with everything on still at 14.1 v.
  4. Range Rover Mark II / P38
    Hi All, Quick question: I just noticed that under my vehicle, a 3-pronged female plug had come undone. It plugs into a 3-pronged male socket on the underside of the engine/transmission area. It is kindof banana shaped. I should have taken a picture of it but I didn't have a camera on me...
  5. Range Rover Mark II / P38
    Hi all, I'm a newbie to this forum having bought a 1997 4.0 SE a couple of weeks ago in the UK. It's my first Range Rover and I checked it over thoroughly, test drove it, etc. Didn't notice anything amiss, the EAS was working fine, would cycle through all the height levels and no warning...
  6. Range Rover Mark II / P38
    Sunroof was unplugged and plugged it back up it works but wont slide back? p38 I have a 1996 range rover se and when i bought the owner said the sunroof didnt work so i took down the lights in the front center on the roof to see if maybe its unplugged and it was unplugged so i plugged the...
1-6 of 6 Results
Top