Range Rovers Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-18 of 29 Results
  1. Range Rover Evoque / L538
    Hi folks, My gears aren't engaging on my 2013 Evoque. The engine starts fine with no errors; however when I shift the gear (to D, R or S), the car doesn't move at all, and the gear letter keeps blinking, and shows a Transmission Fault on the dashboard. Here's a video I recorded today: April 18...
  2. Range Rover Evoque / L538
    I have a 2012 Range Rover Evoque and have been getting the Transmission Fault Message. I called the dealership who said to bring it in (2 hours away). Before I had time to bring it in, I went to start the vehicle in the morning for work and it wouldn't start. I can't get it into neutral to to...
  3. Range Rover Sport / L320
    I had not driven it for a week and when I backed out of my driveway, Car won't pull forward. I have tried restarting multiple times It shows PARKING brake on first and when I turn it off then it shows "TRANSMISSION FAULT" Any ideas?
  4. Range Rover Mark III / L322
    Hi, Excuse me as I'm new here. I bought this 2007 Range Rover HSE about a year ago. I bought it at a deal as I knew had some issues. The one I'm writing about is the one that has stumped us the most. I've read through previous posts on this forum - some posts are kind of similar but not exactly...
  5. Range Rover Mark III / L322
    Getting a p0563 code, system high voltage. Then it showed a transmission fault limited gears warning. Car will drive but in gears 1-3. Just replaced the alternator and battery. Grounds are good. Anyone have any idea what could be causing this issue?
  6. Range Rover Mark IV / L405
    When it rains it pours. Both my Land Rover and Series III is now both not running. I'm f*#&#+$ed. So I'm turning to all you brilliant people here. The series 3 I knows what's wrong so that's all good and dandy but dropping my kid of a few days ago at daycare something interesting happened. So I...
  7. Range Rover Mark III / L322
    Greetings all, I have a 2008 Range Rover Supercharged, which I've owned for 4 years. It has 133,000 mi on the clock, and as recommended, I changed fluid and filter in the trans. Vehicle has run great until this winter. On cold morning starts, momentarily it fails to engage forward or reverse...
  8. Range Rover Mark III / L322
    This issue came on suddenly when leaving a parking lot. I placed my foot on the gas and the transmission slipped (freewheeled) in 1st gear. The same happened in Manual mode a couple of days later after I was told that some have had luck bypassing the issue in a different sector of the gearbox...
  9. Range Rover Sport / L320
    Intermittent "Transmission Fault" msg and slow downshifting I have read about 10 threads related to "Transmission fault" message on this forum, but they are different from my situation. About 4 months ago I started experiencing an issue where after applying the throttle after slowing down in...
  10. Range Rover Mark III / L322
    Dear Members I'm new to this forum. Posting from Mongolia. My car is 2006 Range Rover L322 HSE. It has transmission slipping problem. This was started about 3 moths ago and that time i flushed tranny fluid and changed new oil and filter which didn't cure my problem. Slipping stayed. Later I...
  11. Range Rover Mark II / P38
    I drive a 1999 4.6L HSE with about 130000 miles on it, recently it started doing something peculiar; when it would shift between second and third gear it would slip little before settling in gear. I took the truck to my mechanic and he thought that is was an internal problem with the...
  12. Range Rover Sport / L320
    Hi All, New to the forum, thanks in advance for any guidance. I have a 2008 Range Rover Sport and up to this point have had no issues outside of a fuel pump replacement (under warranty) when I first bought it. I am hovering around 110K miles. This morning I woke up to my car alarm randomly...
  13. Range Rover Mark III / L322
    This is my first Range Rover so...New(to me) 2006 Range Rover HSE supercharged and could use a little help please. I realize this topic has been covered about 100 times, but I can seem to fine the same issues as mine is having. It had the issue when I purchased it, so the price I paid reflected...
  14. Range Rover Mark III / L322
    Ive been reading and searching for months but couldn't find anything. I have a 2007 Range Rover HSE 4.4L Jag Engine. Car would jerk every now and then from a stop after accelerating and then couple weeks later went into limp mode and wouldn't go more than 10mph. Wouldn't even go up my sloped...
  15. Range Rover Mark III / L322
    Hello all, I have been having couple of issues with my 2008 RR Supercharged. They started one day I was in traffic and raised the car just for the sake of it. I was bored. Since then, the car hasn't been the same.:naughty: I get this Transmission Fault Traction Reduced all the time I start up...
  16. Range Rover Sport / L320
    All, I have a 2013 Range Rover Sport (not the SC version). I received a "Transmission Fault" warning message on the dashboard. Restarted the vehicle and the message went away and hasn't come back. Was this an anomaly common to these vehicles and should I be worried/not worried? Or just take...
  17. Range Rover Sport / L320
    2013 RR sport HSE won't start, check engine & transmission fault messages my closest RR dealer is 85 miles away. yesterday my car wouldn't start...no warning ahead of time...seemed to be battery although couldn't imagine why it would be dead. had it jumped, drove it all of yesterday & it ran...
  18. Range Rover Mark III / L322
    Hi This is my first post to the RR forum but I'm hoping RRPhil or anyone else equally knowledgeable on automatic transmissions may be able to offer me some advice. I have a 2007 L322 TDV8 Range Rover with 70,000 miles on the clock - I have owned it for 3 years. It generally leads a pampered...
1-18 of 29 Results
Top