RangeRovers.net Forum banner

tachometer

  1. No fuel gauge or tachometer!

    Range Rover Mark III / L322
    I changed the fuel pump out yesterday in my rover. After getting the battery recharged, i got the truck running again but noticed that the tach and fuel gauge are not working. The car is also stuck in "DE" mode, meaning i can't switch it back to english in the menu settings. Any thoughts? I have...
  2. Tachometer problems

    Range Rover Classic
    Hi, the tachometer is faulty on my 1990 3.9 V8. It registers nothing at idle, seems to get interested as I get going, very occasionally registers what looks like the correct revs then goes back to zero. It had a new alternator fitted this year and I've had that checked - all OK. Anybody got any...
  3. Warning Lamp positions

    Range Rover Sport / L320
    Hi All, Today, i had a glimpse of a warning lamp show up on my Tachometer, but it was brief and in my peripheral vision, and disappeared before I could look at it and identify the symbol. I was making a hard right, steering to the right lock, out of a parking lot and avoiding a car on the...
  4. P38 Tachometer and Speedometer stopped working at same time

    Range Rover Mark II / P38
    Both Tachometer and Speedometer stopped at same time while driving. Tried different instrument clusters, don't work. Display window still reads all mileage and other functions. What gives? Rick Littleton, Colorado
  5. 2003 Range Rover - Brake, DSC, non-functioning Tach and Temp Gauge

    Range Rover Mark III / L322
    2003 Range Rover - Brake, DSC, non-functioning Tach and Temp Gauge I have read the forums and have not found anything close to what I am currently experiencing in my vehicle. I took it to the dealership and, of course, the car didn't do this while they had it and they said it was not showing...
  6. Light bar under Tachometer and Speedodometer not lighting up

    Range Rover Mark III / L322
    Can anyone tell me why the light bar under the tachometer and speedometer on my 2006 Range Rover HSE is not lighting up? The shift also has no lights on it. They suddenly went out. Not sure if it is a fuse or computer glich? Thank you.
Top