Range Rovers Forum banner
slow
1-18 of 76 Results
  1. Range Rover Sport / L320
    Hi everyone. Bought a Rangerover HSE 2008 last week and have noticed that the car is very slow to take off. You have to put the foot down to get it moving unlike any other automatic which start moving as soon as you take your foot off the brake. There is also a squeaky sound coming from the back...
  2. Range Rover Mark III / L322
    So I purchased a 2008 Range Rover HSE today. It has 192,000. I got a really good deal and it is beautiful in every way. However, I am finding myself underwhelmed by the power compared to my 2003 HSE. I thought the Jaguar motor had more horsepower but I am finding it to be pretty flat. Could...
  3. Range Rover Sport / L320
    Hi Guys. My Sport started shaking weeks ago, especially at lower speed, I can sense the the shaking at a constant pace, I think it is something wrong with one of the wheel. It almost feel like the wheel turns around and shakes and turns around shakes again. At higher speed, I can hardly feel...
  4. Range Rover Sport II / L494
    My RRS 20" black rims developed a slow leak. I took it to a tire shop and they discovered it was some corrosion near the bead and the coating was flaking off in large chunks. They scraped off what was loose and put the ires back on. They said it was likely I will be back in 3-6 months with...
  5. Range Rover Sport / L320
    Hi, I had a shop replace the O2 sensors in the car, all 4 brought from trusty online rover parts we site. Now i am getting P0133/153 And P0171/174 Bank 1 or 2 lean and, Bank 1 or 2 slow response. One or the other after clearing codes. They shop replaced the front bungs on both banks. I...
  6. Range Rover Sport II / L494
    The clock on my 2017 HSE Dynamic is really slow. And I think getting worse. It's loosing about a minute a week. Anyone else experiencing this? (I'm on ICTP 18C). Jose
  7. Range Rover Mark III / L322
    Hi All Well here we go!! My 2004 TD6 Vogue has got a few problems with the exterior lights: Slow indicators. Bi-Xenon not levelling. Side lights flickering. All rear lights on and flickering (including Fogs). Brake lights coming on randomly after ignition key removed. After lots of searching...
  8. Range Rover Mark II / P38
    Hi guys I have owned my 2001 range 4.8 Petrol v8 for a day and I think I have broken it already !, all day it’s been fine I fulled into a turning to turn around, had to be quick as there was a car coming so ( can’t be sure but ) it was still rolling back very slightly when I put it in to drive...
  9. Range Rover Classic
    Hello, I have a 93 Range Rover Classic with a 3.9 EFI which also runs on LPG. Since a week I have the following issue: Cold start, no problem, runs fine and I'm off to work. When the engine is nice and warm still no problem until I get in traffic at the city and take my foot of the throttle...
  10. Range Rover Mark III / L322
    Well, 80k mile truck with issue outlined in title, pointed to be a leaking transmission sleeve and possibly bridge seal. What besides these parts needs to be replaced while in the transmission? Are there any gaskets needed to remove and reinstall the valve body (mechatronic unit I think it's...
  11. Range Rover Mark III / L322
    I am wondering what this noise could be exactly, everytime I turn the car slowly I hear a popping noise coming from the suspension underneath my feet? My question is, is it the air bags that are going out or is it the bushings for the suspension? Thanks.
  12. Range Rover Mark III / L322
    In the 2000 miles I've had my 2010 HSE, I've had to add coolant a couple of times. I'd say about 2 quarts total. It recently got a new water pump prior to my ownership. At first I was assuming it was never topped off sufficiently or bled out enough. Now I'm thinking otherwise. No visible signs...
  13. Range Rover Mark II / P38
    This is my first post, so please forgive me if this is not in a correct section. This vehicle was sitting almost a year and did not crank when I got it. After cleaning the terminals and getting a new battery, it finally cranked but very slow and sluggish. 125 rpm at best. I checked spark and...
  14. Range Rover Mark III / L322
    I just swapped out pads from ceramic to composite 2 months ago and the problem started immediately. under slow speed braking there seems to be a metallic pop. I thought it could possibly be the suspension somewhere, but even with the car stopped adding just a bit more pressure to the brake or...
  15. Range Rover Sport / L320
    My intermittent wipers don't work as they should anymore. They do not have the intermittent function when driving, only fast or not at all. What needs to be replaced for these to work properly again? - Back windows only go down with the control on those windows. They no longer operate when I...
  16. Range Rover Sport / L320
    My intermittent wipers don't work as they should anymore. They do not have the intermittent function when driving, only fast or not at all. What needs to be replaced for these to work properly again? - Back windows only go down with the control on those windows. They no longer operate when I...
  17. Range Rover Sport / L320
    Intermittent "Transmission Fault" msg and slow downshifting I have read about 10 threads related to "Transmission fault" message on this forum, but they are different from my situation. About 4 months ago I started experiencing an issue where after applying the throttle after slowing down in...
  18. Range Rover Mark II / P38
    I'm trying to ask for your expertise before buying lots of parts and dismantling half of the car, so bear over with me... Problem is, my ABS/TC lights come on, when the car is moving slower than app. 2 Kph. Works flawless at all other times. Just changed ABS/TC ECU (fault: Sensor has short to...
1-18 of 76 Results
Top