RangeRovers.net Forum banner

showing

  1. airbag warning light showing constantly

    Range Rover Mark IV / L405
    Hello All airbag warning light showing constantly Range Rover Mark IV / L405 4.4 L SDV8 2018 I would like to hear if anyone has any thoughts on the matter Many thanks in advance
  2. faults showing on screen

    Range Rover Mark III / L322
    my 2003 range rover showed , please check rear fog light on right side, I removed the unit and replaced fog bulb, all is well now but the creen now shows check rear lights although all is well
  3. Text Messages no longer showing

    Range Rover Sport II / L494
    Well after another two weeks in the shop I finally have my sport back. So far everything is working however my text messages no longer pop up on the screen as they used to. Using the same phone, iPhone 8, does anyone have any idea on how to turn them back on? My settings under rover have show...
  4. 2018 Text Messages No Longer Showing

    Range Rover Sport II / L494
    I have had all kinds of issues with my cameras, so was in for the latest update a week ago. Since that update I have all kinds of new issues, but one is that when a text message comes in it no longer comes up on the screen. Does anyone know any tips or something that might have changed? Other...
  5. Message center not showing time

    Range Rover Sport / L320
    This is driving my crazy, Last week the time on my message center went to this —:— and I’m not sure why. I’ve read the manual, the clock on my main display works just fine. Anyone know how I can fix this? I feel like it’s an easy fix that I’m somehow overlooking, but help fix my sanity? Thank you!
  6. Showing navigation when first turned on

    Range Rover Mark IV / L405
    We just picked up our 2018 Range. Is there a way to have the top one automatically show the navigation upon the car starting up? I have to click on the navigation icon every-time I start the car. I also have it on driver dash area, but I prefer the bigger screen for it.
  7. 2010 Range Sport 5.0 showing over 20 fault codes

    Range Rover Sport / L320
    The other day when my wife was driving her 2010 Range Rover Sport 5.0 with 40k miles the check engine light went on. When she got home I checked the codes and received 0x100 P0100-00 Mass or Volume Air Flow Sensor A Circuit 0x101 P0101-00 Mass or Volume Air Flow A Circuit Range /Performance...
  8. GPS showing red line.

    Range Rover Mark III / L322
    Evening all my sat nav shows a red line through the GPS box, I have bought and inserted the latest navigation disc from Landrover but the red line is still there. can anyone advise what I can do next. Thanks in advance
  9. 4 x 4 screen not showing correct gear - RR Dealer Stumped

    Range Rover Sport / L320
    Hi Everyone, I have a 2010 Range Rover Sport SC and I love the truck. I went to one of Land Rover's off-road events and brought my truck. It did great and my girlfriend and I had blast, but the 4x4 info screen continually states my RRS is in "P" Park. Long story short...It does recognize "R"...
  10. changed o2 sensor still showing codes

    Range Rover Mark III / L322
    Hi guys please help can't figure it out 2003 hse 4.4l got this code p0159 o2 sensor slow response bank 2 sensor 2 changed the o2 sensor cleared the codes can drive about 25 miles then always comes back any ideas? can't see any cracks in the wire and checked the connection looks good
  11. HEVAC showing -40ºC after removing Webasto

    Range Rover Mark II / P38
    My 2000 4.6 had a Webasto aux heater when I bought it, since it is not that cold over here and I need the space for an LPG unit I have removed the heater. Carefully tracing down all wiring to get the original state back I have seen the book symbol showing up several times. Everything works again...
  12. 1996 P38 won't start - showing gearbox fault message

    Range Rover Mark II / P38
    Hi, I really need help from you guys, To make a long story short, I took my P38 to be deep cleaned. When I came back the car was outside with the hood open and battery disconnected. They said the alarm had gone of. When I reconnected the battery, the horn was on full blast, and the wipers...
  13. Fuel Gauge showing empty with light on. Fuel in tank!

    Range Rover Mark II / P38
    After I got my non start issues sorted I noticed my fuel gauge is showing empty with the light on. The needle is right down on empty. I hooked up my nanocom evolution and through the BECM settings tried to move the gauge and it did not move. I did the same with the temp gauge as a comparison and...
  14. Box selector showing high and low illuminated

    Range Rover Mark II / P38
    Will be looking at this in the morning, but coming home tonight and both high and low gear lever position indications are lit. The box changes happily in high but I cannot shift to low. Hooking up the Nanocom shows "gearbox shift fault" message and won't clear. I'm hoping that a plug or...
  15. CD Player not showing up on screen

    Range Rover Mark III / L322
    Hello all.. first post here. My 2003 does not recognize the CD function when scrolling through the display with the mode button, just radio and tape. I've done a hard reset and searched this board far and wide for any cause/solution with no luck. I'm wondering if there might be any internal fuse...
  16. Airbag Fault, but showing no faults?

    Range Rover Mark II / P38
    Aloha, I tried this on the P38 forum a while back and got no nibbles, so I thought I would run it by this group. I have an 1999 P38 that says it has an airbag fault on the dash display, however, when I query the SRS system it shows no faults as being present. Instructing the Fault mate to clear...
  17. Climate Control LCD - Parts of numbers not showing....

    Range Rover Mark II / P38
    Backlight is fine. But part of the numbers don't read. Example - When "70" is selected, the top of the 7 does not show. Any suggestions on repair? New LCD required? Source and install instructions if so..... Again - NOT the backlight bulb/s. I have to actually replace one of those too...
  18. Pixel fixed -mileage showing up in odometer field

    Range Rover Mark III / L322
    I have searched with no luck so I am posting the Question! First land rover and I bought a 2004 Range rover with what I thought was 115k on the clock. It had the stereotypical pixel issue when I bought it and I didnt pay any attention to it because of the following... I did a carfax and the...
  19. new blend motors not showing display or working

    Range Rover Mark II / P38
    I have installed the new blend motors on my RR 2001, I have not put the dash back on or installed the radio etc. The heater/AC control unit does operate the fan contorls work and lights up the pushbotton controls. The blend motors are not working and the unit display is not on. I pluged in...
  20. Why is my Dash Board not showing clear??

    Range Rover Mark III / L322
    Why is my Dash Board not showing the numbers and letters clear? Is the bulbs bad or is it something else?? Reply asap. thanks
Top