Range Rovers Forum banner
read
1-17 of 93 Results
  1. Range Rover Sport / L320
    i got 2006 range rover sport 4.2 as a present and all suspension parts and suspension pump have been replaced. i get suspension error and overnight it lowers in the front side of the car. back seems to be fine. error code is c1a13-64 pressure does not decrease when venting gallery. can anyone...
  2. Range Rover Evoque / L538
    This was concerning my charging fault... Topix history shows... SSM74321 - Software Files Missing from PATHFINDER 222 SSM74323 - Unable to log into SDD and PATHFINDER Is that an issue with my car or the dealer? They did manage to pull a code from the body module concerning the fault, but...
  3. Range Rover Sport / L320
    Deleted two this morning, and will continue to delete stuff from folks who are basically too lazy to read the rules. Put your location. Add your rig details to your signature. Try the search function before posting repeatedly asked questions. From the very top section of the forum...
  4. Range Rover Mark III / L322
    Deleted two this morning, and will continue to delete stuff from folks who are basically too lazy to read the rules. Put your location. Add your rig details to your signature. Try the search function before posting repeatedly asked questions. From the very top section of the forum...
  5. Range Rover Mark III / L322
    So my recent buy, 04 HSE rover is lower in front every day. More on left side. I've never pulled the relay to stop self levelling, I figured it was my uneven driveway maybe causing it. Compressor pumps it up in morning quickly, no noise, no shudder, nothing. Start car and pop, its up...
  6. Range Rover Mark II / P38
    I have an 02 p38a and it's been pretty good for quite some time. However today I ran into a new EAS fault on my drive home. Here's my set up right now. All new Airbags all around Rebuilt air suspension valve block replaced heat override on compressor Rebuilt compressor with new piston seal...
  7. GAP Diagnostic
    Is there a way to read which modules have passed the drive cycle. I am fighting with the P0442 fault and need to know when it is ready in order to get it inspected.
  8. Range Rover Mark III / L322
    hi guy's I've just picked up a 2011 range rover (private sale) and when i press sat nav, all i get on the screen is that the map data cannot be read. Can anyone help me please? Many thanks ASH
  9. New Member Introductions, No Questions Please
    As a technical site there is basic info that is required in order to answer questions. Help us help you by following the Forum Guidelines for the above information. It saves time in the forum and provides you with more accurate responses. :thumb: Please provide your Rover's year, model, trim...
  10. Range Rover Mark II / P38
    I've been through the various threads - have a question about something in the sticky under electric troubleshooting. Ghind says 11. This test tells you if your alternator is producing 14.4 volts or not. Strictly not essential to do this test as the numbers above let you work it out...
  11. Range Rover Classic
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  12. Range Rover Mark II / P38
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  13. Range Rover Mark III / L322
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  14. Range Rover Sport / L320
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  15. Range Rover Sport II / L494
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  16. Range Rover Velar / L560
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on...
  17. Range Rover Mark IV / L405
    Hey folks It seems there is an issue that is being investigated (so we're told) about threads with a ' in the title not opening. So if you make a thread about your 2017 etc do NOT put it as a '17. Stupidly, same goes for any other form of apostrophe. So dont put "we're" "aren't" and so on. Yeah...
1-17 of 93 Results
Top