RangeRovers.net Forum banner

range rover classic

  1. Range Rover Classic
    what do you recommend for brake pipes +4 cm, any ideas?
  2. Range Rover Classic
    Hey all. For some background - I have a 1990 RRC SWB. Recently, my catalytic converters were stolen. As a quick fix, I welded new pipes in there (the car is emissions exempt, and I did not want to weld new cats in fear of them being stolen again). It sat for a week or so after this, and then I...
  3. Range Rover Classic
    Hello guys, I’ve tried to search for the answer to this, and also studied diagrams with no luck so far! Wondering if anyone can help!! I’ve got a 94 RRC 3.9 with original rear axle. Spring seats and shock mounts are heavily corroded and the diff is whining so I plan to replace. i will buy a...
  4. Range Rover Classic
    Looking for advice as I'm sorting out the dome lights on my 95 RRC. It's been to two shops and no one is able to figure it out. I've done some troubleshooting as well, and seems like everything's been looked into aside from ripping out the headliner in tracing every single wire to and from the...
  5. Range Rover Classic
    I’ve recently got my 92 Range Rover classic back on the road after sitting for a few months, before it was sitting the central locking and radio worked fine, but now the radio will not turn on, and the central locking seems to pick and choose when it wants to work. I’ve tried accessing the...
  6. Range Rover Classic
    so I picked this car up from my mom, she told me it ran and drove fine until she tried to pull someone that was stuck in a ditch or something out and after that the transmission started giving her issues so she parked it and it sat for like 4 years. I have it now and am trying to fix it up. when...
  7. Range Rover Classic
    I have a 95 LWB. I used a paper clip to read the codes. I’m working to resolve all, but I can’t find 3-10 or 3-11. Does anyone know the cause? I also got 2-3, 2-12, and 2-14. Also, when the ABS, Brake, and TC lights came on, I lost a lot of the braking power. Should the brakes work normally...
  8. Range Rover Classic
    Hi all - Traced down a non-starting issue to an arcing coil wire and replaced it. Car fired up and ran (roughly) and with almost no power (struggling up small hills at full throttle). Came back home and replaced the distributor cap and rotor and now it sputters for a few seconds before dying. I...
  9. Range Rover Classic
    Hi all, I'm debating whether or not to lift my Range Rover. This existential crisis started when I noticed cracking on my tire sidewalls. I've been looking for something replace the 225/75R16 Dunlop Radial Rovers that came with the car - I've always found them proportionally awkward anyway...
  10. Range Rover Classic
    Hi. New member so please bear with me :). I recently aquired RRC for restoration project and and it's got faulty fuel level sensor. The level connector that should give ohm reading shows no conductivity between the sensor body and the connector. I've tried googling the correct sensor a bit...
  11. Range Rover Classic
    I bought my 91 RRC then flew from Portland, OR -----> San Diego with the plan to drive back on CA Hwy 395 through the Sierra Nevada Mountains. 99% of the people I told this to thought I was a little nuts. I was a first time Range Rover owner, I was buying an RRC I'd only seen in pictures and a...
  12. New Member Introductions
    Hey everyone, after years of lurking and months of looking I finally pulled the trigger on my first Rover. She's a 2 owner '91 Trocadero Red RRC with just under 150K and records since new. I've had it for about 4 months now and have racked up about 5000 miles, worked out some not so serious bugs...
  13. Range Rover Classic
    Hey all, The other morning I (hastily) forced the key to turn in the door-handle tumbler. Instead of unlocking the vehicle I snapped something. (Not sure what snapped, but now the key continuously turns in the tumbler w/o locking or unlocking) The snap happened because the lock button got...
  14. Range Rover Classic
    Hello guys! I'm from Istanbul, Turkey and I just paid deposit to a '86 RRC! She has '92 3.9 V8 motor with LPG. I insist on to remove the LPG from motor. The seller is going to deliver the car 2 weeks later without LPG. Actually it's going to be my first Land Rover and also my first...
  15. Range Rover Classic
    My viscous coupling went bad in my blue 95 a while back and I've put off fixing it for a while now but I think I finally have time to tackle the project. I have never done a VC replacement before and there doesn't seem to be much in the shop manual about it. Does anyone know how to replace one...
  16. Range Rover Classic
    Ok, I know this is a bit unusual, but I've searched and searched without finding any ideas. I've finally welded up a new rear bumper on my 1994 RRC which holds a 32" spare tire and a 5 gallon army fuel can. I have all the fabrication equipment i need, so it struck me, here I am carrying a bunch...
  17. General Chatter
    Hi, I have been driving a 1994 Range Rover Classic for quite some time now. In a couple months from now I'll be traveling a lot further than I had been before. MPG isn't a big concern but reliabaily is a huge concern, and I don't want to be left stranded 2hr+ away from home. The newer range...
  18. Range Rover Classic
    hello all I am currently restoring a 78' Range Rover and am in the process of replacing the shot rubbers This has become an issue as I cannot locate any new old stock oem or reproduction rubbers for the rear windows Any help you could give would be appreciated Thanks
  19. Range Rover Classic
    So I recently bought a 1988 range rover classic that's seen more than a few owners, as well as its fair share of wheeling. the only thing that's really got me scratching my head is its miss fire, i thing it could be related to the engine running rich. I hooked it up to a 5 gas analyzer yesterday...
  20. Range Rover Classic
    Just did the 4.6L conversion into my 94 range rover classic, primed oil pump with impact drill intially had 20 PSI then dropped to 10 PSI at the same consistant speed. When I started the engine there was no oil pressure (0 PSI). Suspect oil pump clearence issues. Has anyone seen or heard of this...
Top