RangeRovers.net Forum banner

problem

  1. Range Rover sport 2005 sunroof problem !!!!! HELP PLEASE

    Range Rover Sport / L320
    Afternoon All, I have recently brought my first Range Rover sport. With the hot weather I decided it was time the sunroof came into play, I went and got the car washed last night and realised the sunroof has not completely closed. It appears to have a very slight GAP at the back of the...
  2. Back doors & boot intermittent problem not unlocking

    Range Rover Mark III / L322
    I’ve got a problem with the back doors and sometimes the tail gate not unlocking with the key fob. Found loads of info on line but it’s just confused me more. Any ideas how I can sort this please. Denise 🙂
  3. Problem posting on the Forums?

    General Chatter
    Is there a technical issue regarding posting? When I try and post I get the following message: "Thank you for posting! Your post will not be visible until a moderator has approved it for posting." Is this a new step that has been introduced? If so why?
  4. height sensor problem

    Range Rover Mark III / L322
    2008 range rover hse 150000 miles replaced bothfrn ir struts, lower contrl arm and bushings and compressor t about 120k. 4 weeks ago i replaced a lower radiator hose and then on the drivre home a suspension fault warning came on... since then it has displayed a few times and i have noticedon...
  5. Head Unit Problem L405 Brightness changes itself

    Range Rover Mark IV / L405
    Hello i am new to this board and have a little problem, maybe someone can help me out. My Head Unit Display changes the brightness itself, without any tunnel or something else. Sometimes 4-5 times a minute, it makes me crazy. Try to show this on the attached video. Maybe someone has a...
  6. 2010 tow bar electrics problem

    Range Rover Mark III / L322
    Hello My name is Dominik, I live in Poland and I am a great Range Rover lover. I have just switched from the 2006 HSE 4.4 petrol to the 2010 HSE 5.0 petrol and my first problem is the towing electrics. This is the 2010 model year, so there is no module - only gray plug near the spare wheel...
  7. L405 suspension problem

    Range Rover Mark IV / L405
    Hello to all, This story is about my L405 2013. Suspension problem. She cannot hold standard height. Every time with attempt of changing height she says something like "to make sure clear of obstacles" and raises in to Extended height. I have read many articles here but almost all of them...
  8. Gearbox/Tonque Converter Problem?

    Range Rover Mark III / L322
    Hi, On a 2008 Range Rover with 70.000 miles, on start up from cold when putting the car into drive it and at very slow speeds (maneuvering in a car park) can, the car will regularly appear to shudder rather as if it is going to stall, this occurs in both forward and reverse motion and is...
  9. Ignition problem

    Range Rover Mark III / L322
    Hi to all, apologes if if this has been discussed before many times but I am new to the forum and don’t know where to search. i have got a 2007 HSE TDV8, sometimes when I put the key in the ignition I get nothing, steering wheel doesn’t move no ignition lights, nothing. I take the key out and...
  10. HEVAC display problem.

    Range Rover Mark II / P38
    Hi, I removed the HEVAC display unit to replace two bulbs, the ones for the temperature control switches. The display was working before I took out the unit, but the display has stopped working when I put it back in and connected the plugs. I then removed the panel again, and took it apart...
  11. Problem with trailer wiring

    Range Rover Sport II / L494
    I am having problems with the running lights (tail lights) not working on my trailer. The pin on the wiring plug has no power to it. The turn signals and brake lights work normal. I did find a blown fuse #27 (Trailer side lights) in the passenger compartment Fuse block. I replaced the 10A...
  12. Big problem with intouch duo

    Range Rover Sport II / L494
    Hello, Since I bought my Range in June 2018, I had a big problem whit the INTOUCH PRO DUO. The problem appears every time a plug my Iphone with the car as you can see on the video. I went many times to the dealer where I bought my car. They were not able to fix it as they didn’t be able to...
  13. Heat blend motor problem

    Range Rover Mark II / P38
    Hi all...trying toget through a list of little annoyances on my 51 Westminster.. This week its the heat control motors The original had stripped gears so I picked one up from fleabay. I have the feeling it has been repaired and wonder if anyone has a picture of the timing of the gears / pot on...
  14. Transmission Problem?

    Range Rover Mark III / L322
    Let me first say I'm New to the forum and have searched but couldn't find anything similar to my problem, hopefully someone can help! I have a 04 L322 In the USA with 145k miles. I'm having some sort of problem with the transmission and would like to get your opinions on what it could be. When...
  15. weird stereo problem

    Range Rover Mark III / L322
    HI all, newbie here to the forum and range rovers in general. I bought my first range rover td6 l322 on an 05 plate earlier this year. Absolutely love the car but for some unknown reason i now have an issue with the stereo. The orange light on the source button flashes approx 5/6 times when i...
  16. 2019 Range Rover PHEV - Driver seat massage function problem

    Range Rover Mark IV / L405
    Hello , I picked up my Range Rover PHEV 1 week ago.Everything is okay for now except 1 thing.Driver seat massage function stopped working suddenly, and i can't move back part of the driver seat.I don't get any error lights about it. Does anyone have an opinion about this situation ? Maybe I...
  17. EAS problem

    Range Rover Mark II / P38
    Gents, Driving on the highway this morning, once of a sudden 2 beeps and the display says max 55kph. When I connect the Nanocom the only message I get is can't communicate with ECU, the EAS does nothing, no pump running, when I open the doors she doesn't level herself, the ride height can't be...
  18. Rear washer problem

    Range Rover Mark III / L322
    My dealer told me the rear washer was not working because the hose between the pump and the motor was perished. They wanted $800 to replace. I finally checked myself, the hose is fine, the pump is fine. When disconnecting hose from motor in rear and operating pump plenty of water is pumping...
  19. Stalling Problem

    Range Rover Mark III / L322
    This just started recently but all the sudden when I’m driving down the road it seems like my engine is killing itself for some reason at low rpms. The battery light and oil light come on and my car just dies with no power. I was looking at the forums earlier and it was recommended to change the...
  20. Question about heat / ac problem

    Range Rover Mark III / L322
    Help! My 04' HSE has developed a symptom where only hot air will come from any vent selected. It feels as is the heat is way higher than any hot air which I recall on the coldest days, it feels like the thermostat has completely failed This occurs when - selector under center dash vents...
Top