Range Rovers Forum banner
poorly

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. Range Rover Classic
    Hello, The truck has about 125K miles on it and has usually run very well. We recently moved from Colorado to SJI, WA and the rig has run differently, but all in all fine. I did adjust the timing and idle speed after the move. The other day, I put in about 3/4 tank of E-10 fuel. Prior to this...
  2. Range Rover Mark II / P38
    Hello everyone A friend of mine changed the spark plugs on my range rover to new ones the other night i drove it home was fine but the next day i drove it ,wasnt running healthy at all, it moved but barely had power and it just doesnt sound good at all. I think it wasnt running with all...
  3. Range Rover Classic
    Dear members, My range rover with automatic transmission runs perfectly for the first few moments when it starts while using the 1st and the 2nd gear, but when it reaches a relatively high speed with the 3rd and the 4th gear, the engine starts to perform poorly making a bob-bob like sound. When...
  4. Range Rover Classic
    1992 Classic 3.9L V8 starts when cold, runs smooth for approx. 15 minutes until hot then starts to run ruff until it finally stalls. Will barely restart. No power at all. When placed into gear, really barely runs. Exhaust really smells. No Check Engine Lite, no codes. New distributor, fuel pump...
  5. Range Rover Mark II / P38
    Hi All, Last question from me today. Again just recently, the radio started suffering from interference. 'Old school' I'd question that a suppressor on the back of the alternator had failed or dropped off but I can't see anything there. Do I just need to get a new radio? Again any clues...
  6. Range Rover Mark II / P38
    Hi wise people of the forum! My 99 4.0 thor. Has recently developed a rough idle which seems to correct itself after a couple of seconds. This has just turned into general poor running accompanied by smelly exhaust fumes. So far I have ruled out the IACV and replaced the plugs also the MAF is...
  7. Range Rover Mark II / P38
    I just ordered blend motors, so I'm going to undertake the replacement process when I get those in a week or so. Trying to decide which take-apart directions to follow. My dash doesn't seem to be fitted properly, so I was thinking of removing the dash to access the blend motors, and hopefully do...
1-7 of 7 Results
Top