Range Rovers Forum banner

poor

  1. Range Rover Mark III / L322
    For a long time now, I have not been able to figure out this issue. I used to get pretty decent mileage, averaging about 16MGP. Now I get 10-11, and something is clearly wrong, but no real codes. I have a bad cat, constant P0420, which is probably due to a bad tune on that bank, related...
  2. Range Rover Mark II / P38
    Last weekend I changed the entire exhaust system on my Gems 4.6 – I’ve been having long running over fuelling/lack of power problems, so I changed the exhaust just in case the nasty old lashed up system was impeding air flow, and choking the car. At the same time, the Lambdas have been swopped...
  3. Range Rover Velar / L560
    Many car reviewers commented on poor ride when the roads get bumpy or uneven. What are you owners' impressions?
  4. Range Rover Mark II / P38
    :crybaby2: Makes me sad that some people treat their trucks like such garbage. 1995 4.0 SE. This clearly lived a long and hard life... 170k on oil sticker and its inspection tag was nearly 3 years old. Just thought i'd share.
  5. Range Rover Sport / L320
    Wife has recently started experiencing poor quality sound on her cell phone when using the BT connection in her Range Rover. There is a lot of static/crackling on her end. Upgraded to a new phone and still persists. Dealer can't figure it out unless we want to pay to tear the whole thing out...
  6. Range Rover Mark III / L322
    Hello, I have a 06 L233 I love this truck, seems lately she keeping me on my toes with all the work I’ve been doing to her. One of the latest things I’ve noticed is the radio reception is pretty bad. I’m kind of over using the auxiliary jack through my phone ( the volume level isn’t loud enough)...
  7. Range Rover Mark III / L322
    The high beams on my 99 4.6 turned night into day! The lights on my 04 L322 border on not safe. I live in rural WI and in the morning at 5:30 the roads are very dark. I bought some fancy bulbs at the local autocrat and they are not much better. I spent some time adjusting the height of the...
  8. Range Rover Mark III / L322
    The A/C has always been great until several weeks ago when it stopped blowing cold air and would cycle between sort of cool and not so cool. We popped into the shop for a leak check and recharge. The shop said it was fully charged but the high side was low and the low side high. They suspected...
  9. Diagnostic Equipment
    As some of you might recall, I was having some issues communicating between my Nanocom and the HEVAC system. Well, today, the car battery gave up. I have replaced the battery, and verified the alternator is good, and verified all voltages at various remote points are good. And, the good newds...
  10. Range Rover Mark II / P38
    Bonjour all ! I've read and read these forums, but I can't for the life of me figure out what's wrong with Bob, my MY99, Prins LPG equipped 4.0 Thor P38 ! The symptoms : - Very poor MPG (i'm talking 70 mile range with half a tank) - Lacks a lot of power. Starts, idles fine, and, drives fine...
  11. Range Rover Sport II / L494
    Hello Guys, I took delivery of my 2016 RRS Supercharged Dynamic only a few days ago, and have driven it only 92 miles and used up a half a tank (dealer delivered the truck with a full tank), averaging 7.2 mpg (last shown on the display). I think is way below the average consumption stated on all...
  12. Range Rover Evoque / L538
    Although I am very happy with the car, I am very disappointed with the media and navigation system. Media system : not graphical, album covers not shown, radiostation icons not shown, only text. Navigation system (Navteq Denso 1.2) : - very slow reaction - no possibility to change...
  13. Range Rover Mark III / L322
    I have 255/50/20's Goodyear RS-A all season 3/4+ tread depth. This vehicle is almost scary to drive in snowy conditions. Its quite shocking because my rear wheel drive e320 and Landcruiser with 1/2 the tire tread out way perform it in winter driving conditions. Previously I have owned a P38...
  14. Range Rover Mark II / P38
    Hi guys. Next in the list off issues is the fact I'm only getting 8mpg from my 96 4.0ltr V8. Regularly serviced so any initial pointers or ideas what to check first?
  15. Range Rover Classic
    Once again, I need find myself in a predicament regarding my Classic. I'll be brief and to the point. Symptoms; Starts fine when cold but sometimes it has a really poor idle when at normal operating temperatures. It's an INTERMITTENT fault, so it cannot be head warp. Fuel consumption has...
  16. Range Rover Mark III / L322
    Hi looking for some help. New to this forum. The headlights (dip beam) on my 2002 Range Rover L322 4.4 Vogue work fine, very bright to look at lights but I have got very little light on the road. Have had their levels checked found these to be out and have been re-aligned. But still I have so...
  17. Range Rover Sport II / L494
    Hi all, Wondering if Aintree Green color truly has poor resale value or its a myth? I usually never sell my cars to private parties, just trade them in. I found a 2016 RSS diesel with all the options I want, but it is the green color. I like that color as it is different and I think I had the...
  18. Range Rover Mark II / P38
    I am very disappointed, I took my P38 2000, Diesel engine 2.5 for service for service and upon collection the car now has poor take off, very slow speed and can not go beyond 70 miles an hour even with the accelerator right down. The gears appear not to be engaging. I dont hear gears changing...
  19. Range Rover Mark III / L322
    My 2004 Range Rover runs great until it gets below half a tank. Once it gets below the half tank mark it starts to act like your running out of gas. I do have a service engine light on and it's giving me 4 codes p1173, p1170, p0463, and p0705. None of these codes give me a possible cause. Also...
  20. Range Rover Mark III / L322
    Hello all. Today i was driving my truck and it seemed to lose all power! I drove it back home very slowly it was popping and bogging out pretty much the whole way home. The CEL did come on and it read too lean in both banks. I have already tried changing the maf sensor and i noticed that when it...
Top