Range Rovers Forum banner

move

  1. Range Rover Classic
    92 RRC (no memory board) Completely disassembled and cleaned the seat switch. Second time doing this. The first time, I used a bit of superglue to hold the bearings to the top of the tiny springs. I thought that was the issue and it took a while to clean up (got all of it) and reassemble...
  2. Range Rover Mark II / P38
    Dear all I have my lovely Ranger Rover p38 4.0 SE, I have a brake down of the abs PUMP, I come to resolve it, now the vehicule dont want to move, when I put the reverse, I have the idea it want move in front but not in reverse, the GEAR are...
  3. Range Rover Mark II / P38
    Hi all, I have an issue with the drivers seat not moving. I have replaced the outstation with one from ebay, the BECM power board has been replaced along with the seat switches. I have power from the BECM to the Outstation and power from the switches to the Outstation, but it still wont budge...
  4. Range Rover Mark III / L322
    Hello everyone! Was driving back into work on a small incline and my 2005 Range gives the message 'Select Neutral' on the dash and would NOT move forward. The engine kept revving as if in neutral. When I put it in park there was a loud grinding noise. Only when putting in park from any other...
  5. General Chatter
    Hello all, We are reaching out to let our communities know that we have moved the site off our current hosting platform to Google Cloud today. If you notice any issues, please report them in the Community to Team section and we will get them addressed ASAP. Thanks in advance, Your...
  6. Range Rover Evoque / L538
    Hello, New to the forums. My 2013 Evoque had a rough morning. I was driving on the highway, exited and came to stop. I started to drive and when it went to shift gears it revved high up 5 which it never does. This is in Drive and not Sport. In Sport it will go up to 4 normally. I coasted...
  7. Range Rover Mark II / P38
    Hi Guy's, a mates p38 has a problem with the gearbox.. When you select drive, it drives but slow (almost like the clutch is slipping), but if you put it in low range it seems to be ok (not slipping). Ive plugged it in with my nanocom & doesn't show any faults. Can anyone help me with this...
  8. Range Rover Mark II / P38
    Hi. RR P38 zf 4hp 24 i have same problem: "I have a 4sp ZF, when I select “D” the vehicle won’t move, when I select “1” the vehicle moves off. I can then select “D” and continue to drive normally. If I stop I have to start in first again." Solutions for this problem: "A sprag clutch has...
  9. Range Rover Mark II / P38
    My transmission will not start on the selector is moved to drive D you have to move the selector to 1 start moving forward and then move the selected to drive in the transmission as normal, as soon as you're slow down below 5 mph it'll come out of gear has to stop and you have to should switch...
  10. Range Rover Sport II / L494
    Ouch! https://m.facebook.com/story.php?story_fbid=1983752661904167&id=1738267636452672
  11. Range Rover Mark II / P38
    I have a 2000 p38 4.6 it has been very well maintained..with 186,000 miles. Just yesterday I was driving on hwy about 75 to 80 mph...got off hwy drove to a 711 to get a drink. Got back in car..she fired right up as usual...i pulled out drove about 50 feet and had to stop for railroad train...
  12. Range Rover Mark III / L322
    Hello At cold start my transmission sometimes doesn't move in drive. The engine just revs and then transmission fails safe program message appears. It usually takes a few tries for it to engage in gear after shutting the engine off and on and moving the gear selector from park to drive back and...
  13. General Chatter
    not very technical but since my stroke last april i struggle to the tyre compressor/inflator onto the tyre valves my company car has a little 12v compressor which screws onto the valve which makes it easy - try as I might i cannot find a pipe/replacement for my air compressor which will screw...
  14. Range Rover Mark IV / L405
    While not new to others, coming from an MY14.5 into an MY17, the climate seat controls are one of my favorite new features - just daily delight when compared with how bad it was prior. Adding a second level of function with the same control like they did was genius. So much functionality...
  15. Range Rover Mark III / L322
    I'm new to this forum so please bare with me . Here is my problem i have a 2003 l322 with 130,000 miles and i have had no tranny problems or warnings until just the other day. The rover has been driving perfectly got in it the other morning and put it in revers and it felt like the brake was on...
  16. Range Rover Mark II / P38
    Hey there all! been lurking a while as I get our 97 4.6 back up to snuff, thanks for all of the info you have provided! I'm hitting the stage where the engine is coming out for a serious bit of R&R. At 214k miles, we have to put a full dose of oil in over a 300mile trip. My issue is this. I...
  17. General Chatter
    ...and current Range Rover price point slot to be filled by next gen Discovery as it goes more upmarket as well. REPORT: NEXT-GENERATION RANGE ROVER, DISCOVERY COULD MOVE UPMARKET Land Rover will introduce a new generation of its venerable Discovery SUV in 2017, which will replace the LR4...
  18. Range Rover Mark III / L322
    So my mirrors don't move. Side view. Now if I am reading correctly if it were the fuse, the fuse that goes to them also controls the front seats. Everything inside works flawlessly, everything in the vehicle does. I checked the fuse, I forget the number but it was good, I changed it anyway...
  19. Range Rover Mark II / P38
    My daughter just called and said her 2001 rover won't move in Drive she said what ever gear she puts it in the engine just revs but won't go anywhere i had the gear box rebuilt a little over a year ago so i don't think thats the issue its been shifting fine with no noises and there is no...
  20. Range Rover Mark II / P38
    Hi, we have a 2000 Range Rover and I have a problem with it that whenever I put it in any forward gear (hi or low) it revs but doesn't move forward hardly at all (like if the clutch was slipping really bad but its an auto) If I put it into reverse it moves fine. any ides as to what's happening...
Top