Range Rovers Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-18 of 18 Results
  1. Range Rover Mark II / P38
    Greetings from a wintery Melbourne, Australia. It's getting cold so it's time to get the heating working properly. My issue was that the car would go both to HI and LO on the temp controller but not hold correct temp in between. All checks done on the HEVAC test page and all seemed well...
  2. Range Rover Sport / L320
    Hey guys Looking to get a '10 sport n/a for a good friend of mine. It's a bargain, for a reason... Seller says it over heats after @40 minutes of driving. I priced it assuming head gaskets, at which time I'd go ahead and do all the timing chain stuff. He'd still be well ahead. Never had one get...
  3. Range Rover Evoque / L538
    hi my name is aron and im from iran. we have a rang rover evoque and when push keyless button in display message show ”Please switch engine on or system will shutdown in 3 minutes” and car engine doesnt work does any one to help me to slove this problem?
  4. Range Rover Mark II / P38
    Hello, Wondering if you can shed some light on my problem. Day1: was driving the day before on a highway and the engine just shutdown. I coasted down the hill to the nearest ramp and tried starting again, it wouldnt. Had electrics, engine turned over but wouldnt start. Had it towed...
  5. Range Rover Mark III / L322
    L322 Vogue 2002 4.4 V8 with sat nav. Hi, I've read about issues with intermittent sound but this is specifically you always get sound after turning on the radio for a minute or so then it mutes. Turn radio off and on and sound for another minute. I changed the original screen for an android...
  6. Range Rover Mark III / L322
    I have a 2007 and recently we replaced the water pump, thermostat, air filter, battery, and sealed the head gasket with sealant. After all of this my check engine light when off. After taking it on a test run I noticed after 15 minutes it lost power, slowing down to top speed of 30 and crawling...
  7. Range Rover Sport / L320
    Hi All! My 2013 RRS was delivered to me two weeks ago (a two hour drive for the sales person - great service), but I immediately received a "Warning. Low Battery. Please switch engine on or system will shutdown in 3 minutes" message on the display when I turn on the car (not the full start) to...
  8. Range Rover Classic
    I have a '95 RR Classic that begins to stumble/backfire/stall when accelerating after the car has been running for 35 minutes. It is almost like clockwork: The car runs great, and then at the 35 minute mark, it has difficulty accelerating but one the RPM's reach 2500 it revs nicely. Here is...
  9. Range Rover Mark IV / L405
    Did the 80k mile service on my parent's HSE, checked things over on my lift, wheel rotate, oil, CAF, spark plugs, detail...:cool: Checked the tires and filled them to the label, 33 front and 36 rear and the TPMS light popped up randomly and I dismissed it at first as it went off on my test...
  10. Range Rover Mark II / P38
    i got a 1998 range rover se 4.0 liter today at 205k miles. its got an engine light on with twelve codes. the scan tool i have is not that good so i couldnt read all the codes but i did detect three misfire codes. when i go to work im going to use the good ol snap on scan tool to see what the...
  11. Range Rover Mark II / P38
    HEVAC testbook after 3 minutes running - no AC when illuminated Hi All, I just had some of the EAS system renewed here in Budapest, Hungary by the local Land Rover dealer after it hard faulted during a holiday in Austria. When collecting the car after the work (replacement compressor, 2 air...
  12. Range Rover Sport II / L494
    The back seat drivers side light stays on for 15 minutes after turning off the vehicle. The salesman said that they have seen it on a few vehicles and nothing they could do about it at this point. Anyone else experience this? Any help would be great. I sign the paperwork tomorrow. I delayed...
  13. Range Rover Sport II / L494
    Know how to check oil level? I stood under my hood for 10 minutes... Ok, so I am more of an experiential learner (don't like instructions). Went to the station after reading the recent post from the guy who didn't add oil and is being declined for warranty. After about 15 minutes I gave up...
  14. Range Rover Mark III / L322
    Battery drained in 45 minutes after leaving rear hatch open!?!? Hi everyone, I have read all of the battery drain problems but couldn't find a similar one to the problem I just had. I was loading the Rover yesterday for a long road trip, left the rear hatch open about 30-45 minutes and opened...
  15. Range Rover Mark II / P38
    Taking final delivery of my truck today and the strangest thing happened. Installed new battery (OPTIMA yellow), poured in 5 gal. petrol, cranked her and one kick and she starts. Left her running for about 20 minutes while I gave her the final look-over and then shut her down. Stepped away for...
  16. Range Rover Mark II / P38
    Half Day Super Sale! Today only—order either our ’96-’98 or our ’99-’02 S.O.S.-Sultans Of Spark ignition Coils and our Live Wire Plug Wires at the same time and save big!! Normal price is $218.00, but today’s special is $169.00!!! Just from 1:00-5:00 pm CST Sept. 19, 2013 ONLY. *Wider Plug Gaps...
  17. Range Rover Mark III / L322
    ...or OSV in BMW speak! Replacement without removing te back of the intake manifold: http://www.youtube.com/watch?v=kKNeN8tR3wM If you hses were in bad shape you may still want to remove the back of the intake to inspec the hoses. Scott
  18. Range Rover Mark III / L322
    Cuts out after 15 / 20 minutes driving dash says fuel injector fault. I have a 2003 vogue td6 auto. I was originally told the low pressure fuel pump had gone. I have since replaced this and the fuel filter. It is still the same. Drives limp as tho it's loosing power and sounds different also...
1-18 of 18 Results
Top