RangeRovers.net Forum banner

loss of power

  1. Range Rover Classic
    Hey all. For some background - I have a 1990 RRC SWB. Recently, my catalytic converters were stolen. As a quick fix, I welded new pipes in there (the car is emissions exempt, and I did not want to weld new cats in fear of them being stolen again). It sat for a week or so after this, and then I...
  2. Range Rover Mark III / L322
    Loss of power at 1500 rpm between 2nd to 3rd ish FIXED I searched the planet to solve this mystery. The problem as highlighted. A couple of months ago I had the fuel pump changed at an independent location here in Los Angeles. $1200. A short while afterward I started losing power at around 1500...
  3. Range Rover Mark III / L322
    I’ve spent considerable amounts of time reading through posts and various websites, so I thought I’d just ask directly… I have an Australian market ’07 Vogue with a TDV8 engine. Between 1750-2100 RPM, I have a shudder – irrespective of vehicle speed. Most prevalent at 100km/hr which is the...
  4. Range Rover Mark III / L322
    So i purchased this suv about a month and a half ago.. had it in a shop for a month before it had the code p0012 and the other one i cant remember but the suv felt strong and responsive but it has rattling very bad took it to the shop they said all my guides were broken and tensioner's were no...
  5. Range Rover Mark III / L322
    Hey guys Firstly - what a great forum. I purchased my first RR 8 weeks ago - 2002 HSE TD6. With the help of this forum I've been able to restore her to her former glory so thanks to all the members for all their helpful posts and solutions. You've literally saved my £1000's but more importantly...
  6. Range Rover Sport / L320
    Hi guys, I've had my range rover sport 08 for a year and had a number of problems from the start. Most recently I have been hearing a slight rattling/rasping noise from the engine as I accelerate and noticed a delayed loss of power. Yesterday the engine light also came on!!! I've also noticed...
  7. Range Rover Mark II / P38
    Hello all, My Rover is running rough and losing power with the check engine light now popping on and flashing. It seems to be burning oil, so I'm not quite sure where to start. It had a complete tune-up last summer with sparks changed and fuel filter changed. So any suggestions on what to do...
Top