Range Rovers Forum banner
losing
1-16 of 18 Results
  1. Range Rover Sport II / L494
    Satellite navigation problem with the screen intermittently not displaying North facing – all 3 modes (N, 2D, 3D) are ok one minute and then it will display only 2D and 3D – then some time later it reverts back to the proper options. Happens in the city - and in the country. The dealer's...
  2. Range Rover Sport / L320
    I'm recently bought a 2009 Range Rover Sport 3.6 TDV8. I have been losing a bit of coolant and topping it up for a few month. During a recent service I changed the expansion tank and Cap. Just in the last week or so the coolant loss has gotten a lot worse and it has started to belch white smoke...
  3. Range Rover Sport / L320
    Hi, its now winter and I switch to winter tires and the Grille in mid November as the temp's start to drop below 6 degrees, and I noticed then when at the dealer putting the winter tires and switch the grille from the OEM 3 bar grille that came with the car, and replace it with the HST Grille, I...
  4. Range Rover Mark III / L322
    In advance I want to thank everyone for your help. My wife wanted a Land Rover so we sold her perfect running with never a problem 2006 Hummer H2.  We purchased a 2008 Range Rover "Supercharged" with 114,000 miles.  Three (3) days after purchasing the Range Rover my wife and son were waiting...
  5. Range Rover Sport / L320
    I was driving at highway speed and just noticed I was slowing down, no engine light, no battery light, and gas pedal doing nothing. I pulled over to slow lane, downshifted manually, and was able to make it home last few miles with manual "bump" assist. Any ideas where to begin? I'm in...
  6. Range Rover Mark II / P38
    Changed injectors, filter, regulator, and pump (not whole unit just the pump). What else could it be?? Every time I start it I need to turn the key forward a few times to prime it. Running out of ideas.
  7. Range Rover Mark III / L322
    Hi all. I apologize if this issue has been resolved on here, but I couldn't find. Yesterday the upper radiator hose blew off the water pump collar and lost most of coolant. I fixed the hose. Topped up coolant and drove for less than a minute and overheated up to red zone. Sat overnight...
  8. Range Rover Mark III / L322
    Hi, Just wondering if anyone has experienced the same symptoms as mine. I've read quite a few threads with regard to similar issues, but none seem to be an exact match to mine. I have a RR 3.0 tdi on a 53 plate which seems to intermittently lose all forward gears. Reverse is fine and so...
  9. Range Rover Mark II / P38
    Hi i have the 2.5 td manual and some time when i am driving it in any gear it feels like it just losers power for like 2 seconds and then its fine again. Its only just starting to do this over the last few weeks now. But it was only when i was doing about 30 mph in it then the other day i was...
  10. Range Rover Mark II / P38
    2001 DHSE So getting despondent now. Air bags not leaking, stood all week at motorway height. New valve block. Today, fitted brand new pump!!! And yet, can not shut the bloody thing up......keeps running. 5 secs here and there....as expected but then 2 minute burst. I do have a question, in...
  11. Range Rover Mark II / P38
    2001.DHSE So as some of you know I swopped my front sensors over as Hawkeye indicated that I had a Front Right sensor fault. Swopping them killed the fault. I tested the rheostats, all good for the swop. Then the car would not lift, or sometimes it did real slow. It was suggested that I get...
  12. Range Rover Mark III / L322
    When driving my 2003 range rover vogue, after a while if I slow down, say to climb a ramp or at a traffic intersection, and then accelerate to move on, it loses power and won't pick. Instead it drags on on a single gear flatly for a about a minute and then begins to pick up. The only way to...
  13. Range Rover Mark III / L322
    Losing coolant from back of engine - need some plumbing advice Hi, I've recently bought a 2003 RR Vogue 4.4 with LPG. It intermittently loses a lot of coolant from the back of the engine and I think its the short pipe thats been discussed on this forum somewhere. Its ben botched up with a pipe...
  14. Range Rover Mark III / L322
    I have a new problem.... The drivers door key lock just turns losely and does not lock/unlock the doors. Also, I sync the key and it works until the ignition is turned and then nothing, no central locking. There is no way to lock it! Regards Warren
  15. Range Rover Mark II / P38
    So, Daisy's having issues again (surprise surprise) this time it's the ABS brake system. The ABS system is losing pressure overnight and the pedal depresses all the way to the floor with little braking effect. When the key is put in the run position the ABS pump runs and shuts off at which...
  16. Range Rover Mark III / L322
    Hi all. I just finished replacing my radiator and that is working fine but now when I drive the steering wheel gets real stiff (kind of like when there is no power steering fluid). My check engine light also comes on and I am getting the codes p1171 and p1174. I know my pcv system is bad and i...
1-16 of 18 Results
Top