Range Rovers Forum banner
loosing
1-8 of 10 Results
  1. Range Rover Mark III / L322
    Hi I have a 2003 hse td6 . if not used weekly battery will lose charge. It has new battery fitted recently.noticed hum from dash and removed top module with fan controls and found air scrubber motor jammed. Freed motor but seems to run constant even with ignition off. remove power plug when...
  2. Range Rover Mark II / P38
    Have replaced hi low range transfer box shift motor and transmission controller but only getting power to shift motor for 2-3 seconds then loses power any suggestions? Thanks Jimboy
  3. Range Rover Mark II / P38
    I have a 2001 RR 4.6HSE with 200,000 miles on it. Every day I'm loosing about 1/4 inch of coolant in the expansion tank through the overflow tube. Any thoughts on what could be causing this? Any help would be appreciated. Thank you, Mac
  4. Range Rover Mark III / L322
    I find a lot of threads with a sync problem but nobody that has solved it and posted the solution apart from getting a dealer to reprogram.the ECU as i have done twice. i have an 04 range rover petrol 4.4 that when i disconnect the battery i have to get the main dealer to come out with their T4...
  5. Range Rover Mark III / L322
    Can someone tell me what might be happening to my RR recently when starting my car it has been losing power steering sometimes when I pull over and take the ignition key out and back in the power comes back and sometimes it doesn't also the central locking would open the front car doors but not...
  6. Range Rover Mark II / P38
    AC Low side is covered in ice and AC is loosing its effectiveness ? So when i picked up my P38 today to drive it the 170 miles home from the dealership the AC was so cold its was almost freezing the wedding ring off my finger as i drove.Just around the 100 mile mark it suddenly lost its arctic...
  7. Range Rover Mark II / P38
    Hi all, I have to top my water expantion bottle up every week, I do about 80-100 mile a week & when I check my levels every Sunday before I start my weeks work on Monday I use between 1-2 litres of water, everything seems fine, it pulls great & there is no smoke out the back, it's just sailed...
  8. Range Rover Mark II / P38
    I own a 1995 Range Rover P38 4.6 HSE (Australian Delivered). The problem that I am having is that the engine loses power and eventually stalls after I have been driving for a while. The car will started again after a few minutes and drive but will then loose power and stall again after a short...
1-8 of 10 Results
Top