Range Rovers Forum banner

immediately

  1. Range Rover Sport / L320
    I have a 2010 RRS SC that I have just bought. I replaced the water pump because the dealer said it had a small leak. I used genuine LR parts, replaced the water pump, plastic tube deal, and o ring. When i add coolant, it immediately starts dripping out from what I think its the plastic tube. I...
  2. Range Rover Mark III / L322
    Hello, Having a strange problem this morning.. my 2003 HSE has been running great. I was running some errands this morning, parked the car, when i got back i started it and it immediately stalled out. It will crank and restart, but instantly dies out. If i floor the gas pedal it was sputter and...
  3. Range Rover Sport / L320
    I have an occasional problem with my vehicle; my independent tech tells me it is not throwing codes. Vehicle starts, and immediately dies. When the vehicle dies, the gauges drop to zero and the idiot lights go off, but my nav screen remains on. Because my vehicle does these things when I...
  4. Range Rover Mark III / L322
    Searched but haven't seen this discussed. After parking and exiting the vehicle, the rear end immediately releases one or two bursts of air and drops, causing the L and R sides of the rear end to "sag" simultaneously and equally to one another. Happens most of the time but not always, even...
  5. Range Rover Mark II / P38
    As soon as I switch the engine off the car drops to all four bump stops within seconds and won't pump up If I pump it manually it stays up, while engine is running, goes higher and lower without a problem If I remove the fuse the back lowers gradually - from normal to bump stops in 5 days, front...
  6. Range Rover Mark III / L322
    P2098 Code and engine service light come on immediately when put in drive. Long time Rover Owner but L322 Newbie here. I have a problem with my 2006 HSE that has me scratching my head. P2098 Post Catalyst Fuel Trim System Too Lean Bank 2 with a service engine light. I understand what the code...
  7. Range Rover Mark III / L322
    2007 HSE Stalling Immediately After 1st Start, Then Starts Fine The past few days the vehicle has been stalling immediately after I start it in the morning. It cranks fine, starts, then the RPMs fall, it struggles a bit, then stalls. I start it again right after this and it starts up just fine...
Top