RangeRovers.net Forum banner

hotwire

  1. Range Rover Classic V8 3.9EFI Hotwire engine

    Range Rover Classic
    When starting the engine it has to crank a long time before firing up, doesn’t matter if engine is hot or cold, it will always start and it runs well, no idle issues, no stall issues. I am tearing my hair out trying to find the fault.Any suggestions as to what would cause this?Back groundNEW...
  2. Lucas Hotwire System 14CUX in detail

    Range Rover Classic
    crusin lanyzone found this link....it seems to be well put together http://www.britishv8.org/articles/rover-14cux-efi.htm mike
  3. Hotwire Blower motor, how?

    Range Rover Mark II / P38
    Hi guys. My passenger side blower motor has not been working since I got the car (LHD). I got a new one of eBay UK and it works fine but air is not blowing as hard as it should through the vents. I realised after som searching that this is due to that the blower motors in RHD (British) cars...
  4. 1990 Hotwire continues fuel pump run!

    Range Rover Classic
    Hello,1990 RRC (Lucas 14CUX) brought to our workshop ,when you turn ignition ON ,fuel pump runs continuously!(not doing that 3 sec common energizing!)the engine performs poor in demanding loads. i reckon the pressure does not build-up in rail! any similar experience?RegardsMassoud
  5. A great site explaining all the components of our Rover 14CUX Hotwire EFI system

    Range Rover Classic
    A great site explaining all the components of our Rover 14CUX Hotwire EFI system For anyone who's trying to understand all the components involved in troubleshooting our EFI system I've found this site to be really useful: http://www.britishv8.org/articles/rover-14cux-efi.htm. John
Top