RangeRovers.net Forum banner

firing

  1. Check engine light and cylinder not firing?

    Range Rover Sport / L320
    Hi All, I have a 2011 RRS with 125k miles. The check engine light came on a few months ago. I brought it to my indie repair shop and they ended up replacing the fuel pump, ignition coils, spark plugs and also performed the standard 120k mile service. These items did not fix the issue and the...
  2. SRS Help - Airbag Firing Circuit 1

    Range Rover Mark III / L322
    Hi All, 2006 Range Rover, 4.4L NAS spec SRS light turned on this morning and has persisted through several ignition cycles. Code Reader indicated the fault was "Driver Airbag Firing Circuit 1". No code number provided. From what I gather, it could be a bad ground, or an issue with the rotary...
  3. Firing order on 1999 4.6 HSE A/T

    Range Rover Mark II / P38
    Greetings from Cape Town, South Africa. My question revolves around a 1999 Range Rover 4.6 HES petrol A/T. We have renewed the plug leads and have googled/Auto Data'd, etc., etc., for the firing order, but the number of variations are overwhelming. Can anyone out there please help us with the...
  4. 03 RR HSE firing order

    Range Rover Mark III / L322
    No 2 ignition coil went bad on my Range. I received my new coil a few days ago, does anybody have the firing order, or know where cylinder 2 is?
  5. 89 won;t start. Need firing order/no 1 cylinder

    Range Rover Classic
    I have an 89 Range Rover Classic, that I had to change exhaust manifold gaskets on, and a bolt broke, so I had to take it off to get it it fixed. Since the truck was running fine when I took it apart, I had marked the distributor and used those marks when I put it back together. I got 6...
  6. Can someone please tell me why my injectors aren't firing?

    Range Rover Classic
    I've checked for power at every conceivable place I could think of to check power. That includes using a noid light at the injector connections & they've got power. The light is flickering. I've got fuel at the rail, yet my plugs are dry. Could the pulse signal be weak? I'm stumped. I've done...
  7. Engine miss firing

    Range Rover Mark II / P38
    I have a 1997 4.6 Petrol RR 200,000 Km well cared for. The car runs perfectly 99 percent of the time, starts good. Can drive long distances and smooth engine and everything normal. Now if I go out bush here in Australia around bumpy tracks the engine is smooth and no missing. But sometimes after...
  8. Firing Order

    Range Rover Mark II / P38
    Hi to All I have a Range Rover Year 1999 4.6L V8 HSE engine. The car came to renew the the two ignition coils. While removing the high tension lead from the ignition coil I didn't pay attention to marked the high tension lead according to the firing order. But I am sure that each coil supply...
  9. Mysterious No7 Cyl not firing

    Range Rover Mark II / P38
    Hi guys, 4.6 HSE '99 Stumped! Number 7 just stopped firing. I changed leads, nope. Then plugs - nope. Then coil ----nope!???? Still no No7 Does any wonderful person have a solution? I was thinking a new crank sensor or cam sensors? Best regards to all Mike
Top