RangeRovers.net Forum banner

fine

  1. Restricted performance mode, but now seems fine?

    Range Rover Sport / L320
    We were coming home from a roadtrip this weekend in my 2012 Range Rover Sport Super. Overtook a truck on the freeway, probably hit about 85mph while overtaking in order to pass quickly/safely. After passing, I took my foot off the accelerator to ease back to speed limit, the car suddenly...
  2. Fine Tuning Suspsension

    Range Rover Sport / L320
    Hi Fellas, i've got a free weekend coming up and i really wanted to go through my suspension components because the truck has started riding really rough lately. Here's what i've changed in the past year: all 4 ride height sensors 2 front shock/air springs compressor I did lower the ride...
  3. transfail on auto and sport but works fine in manual and rev

    Range Rover Mark III / L322
    manual on all gears work and reverse works. accelerating from standstill is fine then after that, I hear a whine, feel a loss of drive then BAM! I don't know if its 4th or 5th but transfail shows on the message centre. Its in French so it took me a google translate to understand. manual on to 3...
  4. Replacing just the shocks (air bags are fine)

    Range Rover Sport / L320
    2008 RRS HSE. My shocks are work out but the bags do not leak. Has anyone done just a shock repacement and is it worth it?
  5. All warning lights on and starts fine.

    Range Rover Classic
    I recently bought an 89 country and when I cranked the bad boy up this morning all the lights were on. It started fine and drives and stops fine. I'm new to the classics and I have never seen this before. Before I dive in, what are the common causes of this problem and how do I troubleshoot...
  6. fused 4 failed message (it's fine) and stuck in low

    Range Rover Mark II / P38
    Well I am really sorry to bother you again.. i sincerely hope this is the last I am posting about the P38 from hell. (just for my own sanity, I have restarted and repaired 5 others in the meantime and all went fine, this one is the worst ever) FYO it is an italian market Diesel Manual late 1996...
  7. Engine rebuilt, drove fine with multiple stops then no start

    Range Rover Mark III / L322
    2:00pm, EAS engine codes all cleared, engine idles good, no light 2:24pm, shutdown once to get gas, upon restart, "HDC Inactive", "Air Susp. Inactive", ABS/traction control lights. 3:00pm, engine started, drove with all those above lights on for 45 minutes and shutdown 4:11pm, engine started...
  8. 97 4.6 HSE starts fine, but won't start again until sitting

    Range Rover Mark II / P38
    My 1997 Range Rover 4.6 HSE starts fine when it's been sitting for a while. If I, for example, turn it off to get gas or make a quick stop somewhere it will not immediately restart. If I immediately try to restart it after shutting it down it only cranks but never sounds like it's getting fuel...
  9. '89 SWB Rangie was running fine sat for 6 mo cranks no start

    Range Rover Classic
    I'm pretty sure it is something in the fuel system (before sitting, I drained the tank and put in a new inline fuel filter). Most of the components around the engine are new or rebuilt. Cranks like it wants to spring to life but no such luck. Any tips to troubleshoot? I've spent about all I can...
  10. Extremely rough ride but the dealer says everything is fine?

    Range Rover Sport / L320
    I have a 2011 RRS and I've told the dealer that the vehicle has a very rough ride when driving over 35mph and hitting man hole covers, bumps in the road, bridge joints ect. The RRS bounces violently sometimes and I have to grab tight on the steering wheel to keep the vehicle from swerving...
  11. wont move forward very well but reverses fine

    Range Rover Mark II / P38
    Hi, we have a 2000 Range Rover and I have a problem with it that whenever I put it in any forward gear (hi or low) it revs but doesn't move forward hardly at all (like if the clutch was slipping really bad but its an auto) If I put it into reverse it moves fine. any ides as to what's happening...
  12. 91 RRC Brake Light Not Working, But Car Running Fine

    Range Rover Classic
    I took the Rover for a drive today and notice i have no brake lights. I would like to change out the fuse(if it's that) but having difficulty locating the proper fuse. Is it the fuse box on the dash near the AC or is it under the drivers seat? If its located under the seat, how do I access it...
  13. The usual - HDC, reduced traction - battery fine but reduced gears

    Range Rover Sport / L320
    The usual - HDC, reduced traction - battery fine but reduced gears Hi all, been using this forum as a diagnosis tool for a while, but I've come across something which combines multiple regular faults, but seems unique. I'll give you a run down. - Had the brakes changed (discs and pads) in...
  14. Heater Blower NG but AC Blower is Fine. WHAT ??

    Range Rover Classic
    My heater blower doesn't work but in AC mode the fans work just as they should. Any ideas why heat is not blowing?
  15. Hand crafted luxury grilles for your Land Rover

    CARiD.com
    The Land Rover has been responsible for manufacturing some of the most stylish, decent and luxury SUVs in the world. It contends for that endlessly debated “world’s best” title. If you expect nothing but the best out of life, and looking to add a decent custom touch to your Range Rover check out...
  16. Down to Stops Yesterday, Air Suspension Fine Today?!

    Range Rover Classic
    Yesterday night my air suspension went down to bumper stops. I luckily wasn't far from home and I drove it there. Air controls were non responsive, but there was no warning light. Today I went out and turned on the rover and it inflated up no problem. Is it possible my compressor is on its way...
  17. RRC 1987 Engine don't start on petrol but run fine on LPG

    Range Rover Classic
    Hi guys First I just want to say thank you. I found a lot of answers thanks to this forum !Here is my problem.I can't start on petrol or if it start it stall just after. And it doesn't smell fuel when I try to start.I can start on LPG and drive without problem.So I was thinking that the problem...
  18. 93 RR 3.9 Manual KA Chassis no initial flat accelerator on Petrol runs fine on LPG

    Range Rover Classic
    93 RR 3.9 Manual KA Chassis no initial flat accelerator on Petrol runs fine on LPG I have a 93 RRC with the 3.9 EFI V8 it has LPG and is experiencing an inital acceleration problem which is particular to running on petrol. When you go to start off from being stopped in first gear you squeeze...
  19. Odometor not lighting up after bulb change. All other dashboard lights working fine.

    Range Rover Mark II / P38
    Odometor not lighting up after bulb change. All other dashboard lights working fine. A few years ago I put Leds in my dashboard with everything working fine. Odometer lights (past week) just went out and I have tried to replace them with OEM bulbs and aftermarket having no results getting the...
  20. Air Suspension Inactive - levels are fine. L322 2004

    Range Rover Mark III / L322
    Hi, I am seeing the Air Suspension inactive message, I can clear it with All Comms, but it returns immediately. The fault reads "Reserviour pressure static when filling". I have checked for leaks. The car holds its height over night fine, and I replaced the front two bags 2 years back. I can...
Top