RangeRovers.net Forum banner

cold

  1. Front blower not working, Baby it's cold outside!!!

    Range Rover Mark III / L322
    Hi fellow Rovarians. I have recently replaced a blown radiator hose on 2003 RR. After that, my front blower motor is not working. Went ahead and tried the "Auto" function and still no luck. Of course, its the dead of winter and freezing :oops: . I have a RAVE service manual but there are no...
  2. Arnott air bags fail in cold weather - customer service is horrible

    Range Rover Mark III / L322
    Arnott air bags fail in cold weather - customer service is horrible Did any one else have a similar experience? In November I bought a new-to-me '05 HSE. It is an Arizona car purchased via eBay (12th rover bought from eBay) from a dealer in Memphis. I live in New Hampshire. When I bought...
  3. Cold Starting

    Range Rover Mark II / P38
    Okay, so I have been having increasing difficulty starting the truck in the morning as it gets colder. it cranks and cranks but won't start. If I wait a moment after the first attempt, then crank again, it fires up. This was the case nearly every morning for about a week; Then it decided...
  4. Preventing the freezing cold weather oil explosion...

    Range Rover Mark III / L322
    After reading several posts here about peoples' rigs blowing oil all over the place after a cold start, I gather it's from any water in the oil separator freezing up and causing blockage in the system leading to extreme crankcase pressures building up. Not wanting this to happen to me, I was...
  5. Air con running cold then hot

    Range Rover Mark II / P38
    Hello and a Merry Xmas to all. Our weather has been heating up lately and so it is time to get the air con circulating. I have noticed an annoying problem that needs to be sorted out before it gets worse. My air con has a habit of running cool/cold as it should and then blasting out scorching...
  6. Idle problem cold engine when it turns to LPG. Fuel trim level -76%

    Range Rover Mark II / P38
    Idle problem cold engine when it turns to LPG. Fuel trim level -76% Hi Have a little problem with my RR 4.6 HSE 1996. Idle problem on cold engine when it runs on LPG. Fine when it reach normal temperatur. Fuel trim level -76%. What does it mean? New MAF, new tornado chip (RPI), new...
Top