Range Rovers Forum banner
cold
1-18 of 224 Results
Advanced
  1. Range Rover Sport / L320
    2005, 2.7 tdv6 no fault codes at all! Engine runs really rough and very nearly cuts out sometimes until the engine is warm - after 5-10minutes. The car then runs perfect.
  2. Range Rover Mark III / L322
    I'm having a strange issue that I can't find documented anywhere online: my climate control is running too cold. If I turn the temperature controls on the driver & passenger side to the hottest setting it will only blow warm air so the blend motor seems to be at least partially functional, but...
  3. Range Rover Mark IV / L405
    Hello guys, I own a 2013 L405 4.4V8 Diesel, very happy with the machine so far, now I'm having a strange smoke that smells to Diesel on cold starts, I start the engine, let it warm and suddenly it starts to smoke inside the engine bay, here's some pics. Anyone have a a clue on what should I be...
  4. Range Rover Mark II / P38
    Interesting situation today. A little cold here, so cranked up the heater to get things warmed up. 26 both sides, slipped it onto auto. 5 minutes later, driver's side, good and warm out of the vents and into the foot well. Passenger's side, icy cold, straight off the AC evaporator. Strange...
  5. Range Rover Sport / L320
    Ok how do I fix this problem. It only recently started blowing cold air out the driver side vents when the heater is on. Also can someone can tell me why the vents in my back seat barely have air flow.
  6. Range Rover Mark III / L322
    Is there a reasonably priced scanner that can be used to reset the air suspension after it shows an inactive message after very low temps? Any suggestions except going to the "stealers" will be appreciated. Tks!!
  7. Range Rover Sport / L320
    Saw a strange issue on my '06 RRS S/C yesterday - I drove out 40-50 miles to the mountains, then hit some deep-ish snow, using snow mode, then got back on pavement, turned off snow mode, and on the highway the engine didn't want to keep warm - I could manually regulate it by downshifting. A few...
  8. Range Rover Mark III / L322
    Hi, I'm new here, but know that there are tons of "air susp inactive" threads, and still decided to start another one... It has been very cold here in Finland for some time now. Temperatures are way below 0 degrees Fahrenheit. My 2002 RR HSE stood a couple of days outside, and then when my wife...
  9. Range Rover Mark III / L322
    Hi guys, I was having a blast with my RRSC 2010 until a couple of days ago, I got out in the driveway to go out to work. Got in the car, started as normal and drove out to the street. After like 30 seconds onto the road, I noticed the ride was pretty hard as I have never experienced this...
  10. Range Rover Sport / L320
    this morn started the car let it warm up for a few minutes, put it in drive would not accelerate pass 15-20 , did like you said put it in neutral rpm did not go pass 3, after driving for a few and restarting it about 3 times it picked up and drove normal, check engine light came on says engine...
  11. Range Rover Mark III / L322
    Noticed a loud Hum when the car is first started on a cold morning, if i had to guess i'd say it was the suspension leveling off but its loud, almost like feedback on the radio, but continues when the radio is off. Any ideas?
  12. Range Rover Mark III / L322
    2003 BMW M62 Range Rover. When the engine hasn't warmed up and the colder it is, the more the symptoms show up. Rough idle, almost wants to stall. If you press on gas, it sometimes will stall or sometimes will rev up. If you put it in gear, the load will cause it to stall somwtimes. Sometimes...
  13. Range Rover Mark II / P38
    When I drive the Range Rover from cold the revs climb then flutter by about 500 rpm. When the engine is warm it’s all fine. I think it’s to do with a temp sensor but don’t know where to start. Anyone here know anything that might help? Thanks
  14. Range Rover Sport / L320
    I've got issues with the hot one side and cold the other, reading many posts I changed the blend motors and it did nothing, gas was reading low on the air con so I went all out and changed the condenser, this hasn't solved the problem, so its the heater core, nightmare job and one that can wait...
  15. Range Rover Mark III / L322
    Hi Guys can any one help? Td6 l322 range rover it's lacking power/limp mode when cold had no fault codes so went to maf disconnect it. runs like a dream so swapped it out but same with new one, unplug it runs fine but I now have fault for low side rail pressure. Smoked it for boost leaks...
  16. Range Rover Mark II / P38
    Here's the story. Truck needs consistent refills at reservoir. Been just using distilled water. I feel as though by now it's a system with nothing but water. It's now cold in Texas. It wont reach operating temp. Stays in the blue or just above. Do I add green or orange coolant. And what...
  17. New Member Introductions, No Questions Please
    Hi I have a 2009 RR Vogue TDV8. No matter what I set the front heater setting on, the rear only blows cold, can anyone help please.
  18. Range Rover Sport / L320
    2006 sport not blowing cold air
1-18 of 224 Results
Top