Range Rovers Forum banner
charging

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 40 Results
  1. Range Rover Mark IV / L405
    Hi everybody with hybrid RR. I have a RR400e from January 2019 and no happy with charging capabilities and options offered by RR. Problem begins after consuming electric power(arrives below 2%). Recovery of braking or slowing down is not sufficient to help. I need a software button to set my...
  2. Range Rover Mark II / P38
    New alternator NAPA 213-9453 (they say equal to AMR2938) and new NAPA battery. Battery steadily discharges after three days to around 9.5V. Voltage at battery when running is @ 14V. Battery charges when it reaches around 9.5 V up to 12.5V by the alternator. Is this the correct alternator...
  3. Range Rover Evoque / L538
    2013 Evoque dynamic, thru this fault 2 weeks ago. After a week, I put in a new AGM battery. Week 2, fault still there... Car is charging fine....old and new battery turned over fine, even in -20C temps. Metering the BMS fusable wire link from ground to battery + shows just 11.4V... Same wire to...
  4. Range Rover Sport II / L494
    Hi, anyone experiencing an issue with USB fast Charging port. I have Android s9 and it used to be when I connected it to the fast charging port (located way down in the center console), the phone would indicate it was indeed Fast Charging. This stopped about two weeks ago. The phone indicates...
  5. Range Rover Sport / L320
    Hi After replacing the batter my Range Rover Sport Supercharged from 2013 the computer is showing red failure and message "Charging system fault" ODB code are: P065B as well as B11DB and P0526. ODB is showing that the battery level is 14V and according to the electrician the car is charging...
  6. Range Rover Sport / L320
    I have fitted a new alternator to my tdv8 Range Rover sport yesterday and after getting it all back together it is not charging the battery! Battery light is on. I have tried another battery to rule that out and also the 5amp fuse is intact. Is there anything else is could be other than a faulty...
  7. Range Rover Sport II / L494
    While doing a little cleaning in the rear seats, I noticed the charging panel under the rear climate controls was "caved in". It was likely accidentally kicked in, but surely this is taught in Design 101: why would you ever have a panel which can be pushed in from the outside without any...
  8. Range Rover Sport II / L494
    I hope everyone has been enjoying their new ride more than mine. I have had the car in the shop more than I have owned it since June. My last current issue that is left is that the USB charging port does not work. The 2 rear ports work fine but not the one under the cupholder for the front...
  9. Range Rover Sport II / L494
    Hi guys, Does anyone has more info about the 32amp option to charge the car? I have a blue 32amp single phase industrial plug at home which I used to charge my Tesla. But I have no idea I can charge the RRS with it. More specs available? What about the wallbox they mention? I can't find any...
  10. Range Rover Mark II / P38
    Hello All, My 96 4.0 has been acting up with the electrical lately. My youngest daughter has been the primary driver of it the last year+. Last week it started with the usual dash notifications - gearbox fault, traction control, ect. I did some quick tests and a few things seemed off. Did a...
  11. Range Rover Mark III / L322
    I have read a number of posts about this, and it seems my tow socket is not compatible with this, due to having no direct feed to the battery. My question is, as the reason I need to try to get power to the car is that the lights were left on, is the tow socket going to have a feed to the...
  12. Range Rover Sport II / L494
    Anyone have any good ideas on a good looking magnetic phone charging kit for the sport. Lots of cheapo vent attachments out there, but I don’t want to cover my vents. Looking to see if anyone has got a nice setup where you get in the car and place the phone on the magnetic charger and get to...
  13. Range Rover Evoque / L538
    I had the RR Evoque since new. It has 27,200 miles. I had replaced the original battery 17 months ago with a NAPA AGM perfect fit battery for the Evoque. Now after 17 months the battery has died again and it was still under warranty so I got a replacement NAPA AGM battery. After installing the...
  14. Range Rover Mark III / L322
    I recently replaced a 12v Interstate flooded cell battery (MTP-49/H8 100AH) with a 12v BOSCH AGM battery (# 49-850BAGM 92AH) in a 2010 L322 HSE LUX. Prior to the replacement, the IIDControl app would show a 13.0-13.2v charging voltage and anywhere from 2.0 to 10.0+ amp charging current...
  15. Range Rover Sport / L320
    Guys, I cannot figure out what is wrong. Today, I had my windows tinted and while they tinted the windows they kept a charger on the battery. Well, when I was getting ready to leave the battery light and critical warning light came on as well as the "System Charging Fault" light came on. I...
  16. Range Rover Mark II / P38
    Hi, My dad's old P38 sits standing since he passed, and when i go home to see mum once a year, I charge the battery, start it all up, take it for a run up and down our short private road a few times to free brakes and scrub disks etc., and then check everything is working and clean and detail...
  17. Range Rover Mark III / L322
    May be a stupid question but Is there any way to adjust the charging rate to allow for shorter journeys so the battery don't end up going flat all the time?? L322 2003 4.4v8 petrol Sent from my iPhone using Tapatalk
  18. Range Rover Mark II / P38
    Hi all I hope someone can throw some light on this for me. I recently bought a P38 4.6 1996 automatic & it broke down on the way home. Rev counter & speedo fluctuations & engine holding back, the car wouldn't restart after turning off so I fitted a new battery & car drove home fine. The car...
  19. Range Rover Sport II / L494
    I have a 2017 Range Rover Sport Supercharged and I had trouble with the battery. I tried charging/jumping/boosting battery to new avail so I got a replacement. I replaced and it starts and runs normal but now I am getting a "charging system fault" warning. There is a clip coming from the...
1-19 of 40 Results
Top