Range Rovers Forum banner
blew
1-7 of 7 Results
  1. Range Rover Mark III / L322
    Hi All, im new to posting here. I previously had a 06 L322 that i loved and sold to buy a raptor. i wish i never sold it. i recently bought a 08 L322 HSE and the day ofter i drove it off the lotm my wife called saying that it went into power reduction mode and the temp was high. i told her to...
  2. Range Rover Classic
    Yo, i'm new to the site, so if there is a thread on this already, please redirect me... I've just replaced the second diff that has broken on my '90 RRC. The first was the front, where a chunk came out of one of the gears. The latest was the rear, where the pin holding the diff gears broke...
  3. Range Rover Mark IV / L405
    Hi All, Just wondering if this is an isolated thing or something others have seen and we should be more aware of. We picked up a new 2017 HSE last month. I took it to a local car wash that I have used with all my other cars. While going through the dryer portion the large hood trim piece...
  4. Range Rover Sport II / L494
    So listen to my day....all is well...sun is shining...and I begin to get my check engine light illuminated upon my dashboard. Ok...not blinking...its Sunday.....will just bring it in to the dealer tomorrow (Monday) as it is probably just a sensor error. Ok....so now, a little later in the day...
  5. Range Rover Mark II / P38
    Hi all, Yesterday the viscous fan on my 4.6 '00 blew up under mid acceleration to enter the highway, as a result I have multiple "ninja stars" nailed on my brand new radiator :shock:. I switch off the engine immediately so no overheating at all (at least I think so). At the very moment I...
  6. Range Rover Mark II / P38
    A couple of months ago, dear Forum, I had occasion to buy a new car. (Read: old car crashed.) Because I have a dog now, in addition to two growing girls, I decided to give up on driving Saabs and start driving Land Rovers. I researched and decided that I wanted an LPG automatic, and six weeks...
  7. Range Rover Mark II / P38
    I have 1995 P38 HSE4.6. Fuse 4 blew I replaced but since then wont change to low ratio - it does nothing no messages just carries on working in high ratio regardless of shifter position. I have manually wired the transfer mnotor and it spins and changes to low ratio (I know from driving it but...
1-7 of 7 Results
Top