Range Rovers Forum banner
amigos
1-5 of 6 Results
  1. Range Rover Mark II / P38
    2001 RR: I’m getting three amigos with firm press to brake pedal. I can hear the pump kick in with a “vrrrt” sound and will do that every 5-10 seconds while the brake pedal is pressed. Im thinking Accumulator replacement? Anything else I should look in to?
  2. Range Rover Mark III / L322
    I have the dreaded 3 amigos ... I have had my wheel speed sensors swapped on front wheels but still end up with "open circuit front right" error had the wiring changed from the wheel sensor to the unit and "voltage" or whatever is measured is ok. Had a new steering angle sensor fitted about 4...
  3. Range Rover Mark III / L322
    2003 Range Rover HSE l322 with 100k miles. The HDC inactive / air suspension inactive message has been intermittent but finally decided to stay on. I used the RSW solution allcoms and in said open circuit right front wheel speed sensor. Thinking it was a sensor, I swapped the left and right to...
  4. Range Rover Mark II / P38
    Hi All, Running out of ideas and need some help on this one .... After 5 minutes running: ABS fault, Traction failure and the ABS and traction lights on but not the middle red one. Done so far: Checked accumulator Pump runs normally Brakes ok but not stunning ABS works -- it operates on...
  5. Range Rover Mark III / L322
    Had the day off today, had to get the Girlfriends Fiat 500 MOT'd, so I gave her a lift to work, she works in the Surrey Hills near Westcott/Gomshall....very nice area and very hilly. Dropped her off and I needed to get some Surgical tubing to fix the fall away rest on my compound bow so I went...
1-5 of 6 Results
Top