RangeRovers.net Forum banner

advance

  1. Range Rover Mark II / P38
    Has anyone tried or heard of advancing the cam timing on the 1999 Land Rover P38 4.6 Bosch engine?? This is not something new to me. I have done this to many of my other later vehicles with very good success, but not Rovers. It's my first one!. I have a 1999 range Rover with the 4.6 Bosch...
  2. Range Rover Classic
    I think I have a bad vacuum unit on my distributor. When I attach a vacuum pump the advance does not move and there is no vacuum build up. Normally this would indicate a bad vacuum unit but I wanted to see if there was something different about this unit that would cause that. Also on the back...
  3. Range Rover Classic
    In the course of getting this new to me '95 LWB sorted out and running well I replaced the faulty vacuum advance on the distributor among several other items that needed attention. I set the timing at 8 degrees BTDC per the manual with the vacuum disconnected. It starts, runs and idles very...
  4. Range Rover Sport / L320
    I just brought home my new to me 2011 RR Sport. I have a yellow triangle with an exclamation point in it illuminated. For the life of me I can't see anything in the owners manual on what it means. It's cold, 19 degrees, so I thought it might be warning of freezing? Thanks
  5. Range Rover Mark III / L322
    Hey everyone. Loooooong time lurker here. Looking for thoughts on where to start when I get back in town with a few errors 2008 Range Rover HSE---105k on her 1. "Transmission Fault: Limited Gears Available"---JUST started one time on my way back home. Wouldnt go above 3rd gear. Shifts...
  6. Range Rover Mark III / L322
    hello - been trying to find the advance auto parts (US retailer) pn or call out for the manifold cover on aft area of engine. no joy so far and i have a nice coupon to spend. very little selection RR wise at their stores - brakes, water pump and oil is about all that i have found. i can find...
Top