RangeRovers.net Forum banner

4.6 hse

  1. 1996 4.6 hse Range rover idle trouble

    Range Rover Mark II / P38
    Hello everyone ! I have searched and searched for answers but I am still having no luck. I am hoping someone could point me in the right direction.. please bear with me as I am writing this on mobile So I have owned a 1996 4.6Leaker Range Rover p38 for 2 years I am proud to have working eas...
  2. Engine Disabled/ EAS Manual on 97 RR 4.6

    Range Rover Mark II / P38
    I went to the store came back the error messages read: gearbox fault, traction failure, abs then the car sat for a week....when I went to jump the car it read eas manual, engine disabled. The car was running well prior and not sure what could be causing these issues.
  3. range rover engine swap

    Range Rover Mark II / P38
    hi everyone My parents bought 19 years ago a range rover p 38 2.5 td. Now they are looking to buy a new one in about 5 years time. This would be a great opportunity for me to own that car. It has some sentimental value for me and therefor I want to 'restore' it a bid. Another reason is that in...
  4. P38 ZF Transmission going into Neutral

    Range Rover Mark II / P38
    My RR is a 2000 4.6 :), very good mechanical condition (now it is), 155k km's . In "D", when driving at any speed in highest gear, and I take my foot off accelerator pedal, it goes into neutral, which gives me no engine braking, unless I force a downshift to 3 using the gear lever :|. When...
  5. Need help with replacement letters please

    Range Rover Mark II / P38
    I have an 02' 4.6 HSE. I really like Powerful UK's replacement Range Rover replacements in titanium silver. They also have HSE, but no 4.6. Does anyone know where I can get matching color 4.6 HSE (3-d) to match the front & rear RANGE ROVER letters from Powerful UK? THANKS!!!
  6. Transmission problem Ugly Noise Static Vehicle

    Range Rover Mark II / P38
    One day I turned my 1999 Range Rover on and placed it on D and gave it gas it did not move then I put it in R and it still didnt move then I put it in P then I hear an ugly noise and felt something vibrating under the vehicle it sounded like putting a bunch of change in a cup and shaking it...
Top